aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/HomeScreen/HomeScreen_0.3.0.bb
diff options
context:
space:
mode:
authorBocklage, Jens <Jens_Bocklage@mentor.com>2016-09-30 14:47:46 +0200
committerBocklage, Jens <Jens_Bocklage@mentor.com>2016-09-30 15:01:32 +0200
commitb3a712ed0f12528b7f8be88065d6f95d527b6641 (patch)
treeb293959aba04bb0414b8392c210239f3df87843a /recipes-demo-hmi/HomeScreen/HomeScreen_0.3.0.bb
parentfaf241c43abeda228789dd26417cea1bfbf900bb (diff)
Implementing app launch and app surface control workflow.
Using WindowManager to control layer and surfaces (ongoing). Defining three layouts. Adding combobox selection feature to popup widget. In the current state it should be possible to launch applications that are available through the Tizen application manager. Known issue: IVI-shell is currently disabled in AGL due to issues (porting to Yocto 2.1.1). Signed-off-by: Bocklage, Jens <Jens_Bocklage@mentor.com>
Diffstat (limited to 'recipes-demo-hmi/HomeScreen/HomeScreen_0.3.0.bb')
-rw-r--r--recipes-demo-hmi/HomeScreen/HomeScreen_0.3.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen_0.3.0.bb b/recipes-demo-hmi/HomeScreen/HomeScreen_0.3.0.bb
new file mode 100644
index 00000000..eb0c1496
--- /dev/null
+++ b/recipes-demo-hmi/HomeScreen/HomeScreen_0.3.0.bb
@@ -0,0 +1,43 @@
+SUMMARY = "AGL Home Screen Application"
+DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderTizen + WindowManager + InputEventManager"
+HOMEPAGE = "https://wiki.automotivelinux.org/homescreen"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+PV = "0.3.0+gitr${SRCPV}"
+PR = "r2"
+S = "${WORKDIR}/git/"
+
+inherit qmake5
+DEPENDS = " qtbase "
+
+# for HomeScreenAppFrameworkBinderTizen:
+DEPENDS += " pkgmgr-info aul "
+# for WindowManager:
+DEPENDS += " wayland-ivi-extension "
+
+LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+SRCREV = "5a040cf1e77872dd567f6ffba50ed79fc27d5822"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
+
+
+do_compile_prepend(){
+ PATH=$PATH:${STAGING_BINDIR_NATIVE}/qt5
+ export PATH
+}
+
+do_install() {
+ install -d ${D}/opt/AGL/${PN}
+ install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/opt/AGL/${PN}/
+ install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/opt/AGL/${PN}/
+ install -m 0755 ${B}/HomeScreenAppFrameworkBinderTizen/HomeScreenAppFrameworkBinderTizen ${D}/opt/AGL/${PN}/
+ install -m 0755 ${B}/WindowManager/WindowManager ${D}/opt/AGL/${PN}/
+ install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/opt/AGL/${PN}/
+
+
+ install -d ${D}/opt/AGL/${PN}/colorschemes
+ cp -r ${B}/HomeScreen/colorschemes/* ${D}/opt/AGL/${PN}/colorschemes/
+}
+
+FILES_${PN} += "/opt/AGL/${PN}/"
+FILES_${PN}-dbg += "/opt/AGL/${PN}/.debug"
+