aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/HomeScreen/HomeScreen_0.3.3.bb
diff options
context:
space:
mode:
authorBocklage, Jens <Jens_Bocklage@mentor.com>2016-11-03 20:31:47 +0100
committerBocklage, Jens <Jens_Bocklage@mentor.com>2016-11-03 20:31:47 +0100
commita883c25ab51609a7b17a0d5707fef7f431af163a (patch)
treee72ddfc938f1c69a1bc08b45f350cc42cb8325c0 /recipes-demo-hmi/HomeScreen/HomeScreen_0.3.3.bb
parentd417114dd3094c18ff3e3722050eaf46830ad280 (diff)
Now providing shared c++ library to be independent from QDBus.
New concept of handling layer in WindowManager. - Three layer are created statically. One for the HomeScreen app (in the backround), one for applications and one for popups. - Apps can position their surfaces free in the assigned layout render areas. By default, one render area is assinged to one surface. Compatible with Qt 5.7 - The HomeScreen MUST create its surface with the id 1000! - This can be archieved this way: QT_IVI_SURFACE_ID=1000 QT_WAYLAND_SHELL_INTEGRATION="ivi-shell" ./HomeScreen & - see https://codereview.qt-project.org/#/c/121297/ for more details Since the WindowManager uses the IVI-shell, the file /etc/xdg/weston/weston.ini has to be changed: -------- [core] shell=ivi-shell.so [ivi-shell] ivi-module=ivi-controller.so ivi-shell-user-interface=/usr/lib/weston/weston-ivi-shell-user-interface [output] name=HDMI-A-1 transform=270 -------- The sequence that is used right now to get you started with WindowManager and HomeScreen: killall weston export XDG_RUNTIME_DIR=/tmp openvt -s weston chown aglglobalapp:aglglobalapp /tmp/wayland-0 su aglglobalapp export `dbus-launch` cd /opt/AGL/HomeScreen ./WindowManager & QT_IVI_SURFACE_ID=1000 QT_WAYLAND_SHELL_INTEGRATION="ivi-shell" ./HomeScreen & Signed-off-by: Bocklage, Jens <Jens_Bocklage@mentor.com>
Diffstat (limited to 'recipes-demo-hmi/HomeScreen/HomeScreen_0.3.3.bb')
-rw-r--r--recipes-demo-hmi/HomeScreen/HomeScreen_0.3.3.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen_0.3.3.bb b/recipes-demo-hmi/HomeScreen/HomeScreen_0.3.3.bb
deleted file mode 100644
index d2c319a6..00000000
--- a/recipes-demo-hmi/HomeScreen/HomeScreen_0.3.3.bb
+++ /dev/null
@@ -1,43 +0,0 @@
-SUMMARY = "AGL Home Screen Application"
-DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderTizen + WindowManager + InputEventManager"
-HOMEPAGE = "https://wiki.automotivelinux.org/homescreen"
-LICENSE = "Apache-2.0"
-SECTION = "apps"
-PV = "0.3.3+gitr${SRCPV}"
-PR = "r1"
-S = "${WORKDIR}/git/"
-
-inherit qmake5
-DEPENDS = " qtbase "
-
-# for HomeScreenAppFrameworkBinderTizen:
-DEPENDS += " pkgmgr-info aul "
-# for WindowManager:
-DEPENDS += " wayland-ivi-extension "
-
-LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV = "824bfd42b0105b0aeffbc33a87285578abda2f3b"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
-
-
-do_compile_prepend(){
- PATH=$PATH:${STAGING_BINDIR_NATIVE}/qt5
- export PATH
-}
-
-do_install() {
- install -d ${D}/usr/AGL/${PN}
- install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/HomeScreenAppFrameworkBinderTizen/HomeScreenAppFrameworkBinderTizen ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/WindowManager/WindowManager ${D}/usr/AGL/${PN}/
- install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/usr/AGL/${PN}/
-
-
- install -d ${D}/usr/AGL/${PN}/colorschemes
- cp -r ${B}/HomeScreen/colorschemes/* ${D}/usr/AGL/${PN}/colorschemes/
-}
-
-FILES_${PN} += "/usr/AGL/${PN}/"
-FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
-