summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-11-30 22:31:14 -0800
committerMatt Ranostay <matt.ranostay@konsulko.com>2017-12-01 06:55:20 +0000
commit1f7119d8aa3e37e2a29ad8990c8e91472a70a3a5 (patch)
tree56985ffeb3ee8a11be664201ac7c4f0daae48fce /recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
parent74e84ca7839d0dab275c12dd63b62c1d6b96080a (diff)
libhomescreen-2017: correct dbus permissions to allow statusbar access
Settings application using bluetooth + wifi bindings was able to change HMI status because of invalid dbus permissions access Bug-AGL: SPEC-1150 Change-Id: Id730c67dc8e20dfc38424247fe68ce16939aff8b Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb')
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
index 4ef42ee6..b78f2f56 100644
--- a/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
+++ b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
@@ -12,9 +12,16 @@ DEPENDS = "af-binder json-c"
inherit cmake
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+ file://org.agl.statusbar.conf \
+ "
SRCREV = "d97eb6052b7652a42d502e5887bd7acf3fc6d91b"
S = "${WORKDIR}/git"
+do_install_append() {
+ mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+ install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
+}
+
RDEPENDS_${PN} = "agl-service-homescreen-2017"
PROVIDES += "virtual/libhomescreen"