summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/low-can-demo
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-07-10 15:13:23 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-08-30 16:31:37 +0000
commit835977411439ffd3745abaeb23354e1ed590a0b2 (patch)
treeb164cdbf85e12d76ff885e596cae64d2fcdbcf86 /recipes-demo-hmi/low-can-demo
parentb38057354fcc2e99f37bb3391d83b562faae59c2 (diff)
Integration Low CAN demo and High Lvl ViWi.
This integration use non automatic post installation at first boot on a board. Change-Id: I0f080c72ec98b9280256de20a45aa847714bebf0 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'recipes-demo-hmi/low-can-demo')
-rw-r--r--recipes-demo-hmi/low-can-demo/low-can-demo_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb b/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb
new file mode 100644
index 00000000..6b8f6b5b
--- /dev/null
+++ b/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Low CAN demo HTTP5 UI"
+DESCRIPTION = "AGL HTTP5 UI to display car metric (speed, rpm, ...) on AGL Distribution"
+HOMEPAGE = "https://github.com/iotbzh/low-can-demo"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI = "gitsm://github.com/iotbzh/low-can-demo.git;protocol=https"
+SRCREV = "df5cf4027d1978bd3ac37d583e711f134dd4a406"
+
+PV = "4.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# Run-time dependencies
+RDEPENDS_${PN} += " low-level-can-service"
+
+inherit cmake aglwgt
+
+AGLWGT_AUTOINSTALL_${PN} := "0"