aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/mapviewer_%.bbappend
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2017-09-11 16:07:39 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-09 21:21:47 +0000
commit9879e35d670df53af43de123ce1804a7296531e1 (patch)
treeb10d4024bc44f2dabed787498b6a64aa70a12a52 /recipes-demo-hmi/navigation/mapviewer_%.bbappend
parent94f35a1364fb97c65f8f027bcc85b71c02dd5967 (diff)
mapview: It should be run user service instead of system
Change-Id: I65dd87561b80765ae2bbff5fc7f903ffe27394a8 Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
Diffstat (limited to 'recipes-demo-hmi/navigation/mapviewer_%.bbappend')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer_%.bbappend5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer_%.bbappend b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
index a4eebfb4..4e89af06 100644
--- a/recipes-demo-hmi/navigation/mapviewer_%.bbappend
+++ b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
@@ -15,7 +15,8 @@ do_install_append() {
# Install systemd unit files
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
+ install -d ${D}${systemd_user_unitdir}
+ install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_user_unitdir}/mapviewer.service
fi
}
@@ -26,6 +27,6 @@ do_install_append() {
#SYSTEMD_SERVICE_${PN} = "mapviewer.service"
FILES_${PN} += " \
- ${systemd_system_unitdir}/mapviewer.service \
+ ${systemd_user_unitdir}/mapviewer.service \
/usr/AGL/mapviewer/ \
"