summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/mapviewer_%.bbappend
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-07 11:53:32 -0500
committerScott Murray <scott.murray@konsulko.com>2018-12-10 18:49:20 +0000
commit6ce8a90c1cdf0af96f4734c652b203fce8bf1929 (patch)
tree36d14078f5e0be6a7ee41568636cbd3c31e8a3fb /recipes-demo-hmi/navigation/mapviewer_%.bbappend
parent98d6acf7b2805e570008eb513ac4aa73a0fa00c3 (diff)
Rework mapviewer and mapviewer-demo
Rework the mapviewer and mapviewer-demo recipes to get mapviewer working out of the box for the cluster demo: - Remove the old on/off scripts, as the intent is that the cluster demo work out of the box on an image built with the agl-cluster-demo-support feature. - The separate weston systemd unit has been replaced with a drop-in over-ride file. - A new systemd unit is installed to configure the network connection to the cluster board. This is required now because the weston unit no longer runs as root. - A systemd drop-in is added to have afm-api-windowmanager@.service depend on weston-ready. This is a bit of a workaround ATM, as the windowmanager service was consistently failing due to Weston taking longer to start with the gst-record feature enabled. It is likely that making this more generic should be investigated. - The mapviewer systemd unit has been updated. Its Install target is now afm-user-session@.target; in my testing this seemed the least invasive solution, as there are some dependency loop issues that currently prevent adding it to multi-user.target. As well, its dependencies have been updated from weston and HomeScreen to afm-api-windowmanager@, which is not entirely ideal, but is about the best that can be done ATM given that mapviewer interacts with the other windowmanager users via Weston, but is not an app framework application. Change-Id: I8826e670ae156edd461cc657acefc86e7836a916 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/navigation/mapviewer_%.bbappend')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer_%.bbappend23
1 files changed, 8 insertions, 15 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer_%.bbappend b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
index 4e89af06..a5597083 100644
--- a/recipes-demo-hmi/navigation/mapviewer_%.bbappend
+++ b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
@@ -3,30 +3,23 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://mapviewer-settings.sh \
file://mapviewer.service \
- "
+"
inherit systemd
SYSTEMD_PACKAGES = "${PN}"
do_install_append() {
- install -d ${D}/usr/AGL/${PN}
- install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}/usr/AGL/${PN}/
+ install -d ${D}${prefix}/AGL/${PN}
+ install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}${prefix}/AGL/${PN}/
- # Install systemd unit files
+ # Install systemd unit file
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_user_unitdir}
- install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_user_unitdir}/mapviewer.service
+ install -d ${D}${systemd_system_unitdir}
+ install -m 644 ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
fi
}
-## DO NOT ENABLE 'weston-mapviewer-demo.service' BY DEFAULT
-##
-## This should be enabled/disabled by 'switch_on_mapviewer-demo.sh'/'switch_off_mapviewer-demo.sh'.
-##
-#SYSTEMD_SERVICE_${PN} = "mapviewer.service"
+SYSTEMD_SERVICE_${PN} = "mapviewer.service"
-FILES_${PN} += " \
- ${systemd_user_unitdir}/mapviewer.service \
- /usr/AGL/mapviewer/ \
- "
+FILES_${PN} += "${prefix}/AGL/${PN}/"