summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/mapviewer_%.bbappend
diff options
context:
space:
mode:
authorynakamura <ynakamura@jp.adit-jv.com>2016-12-28 14:57:00 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2017-01-25 04:37:42 +0000
commit219e576cc39946ba717ac7c8db5af912a44d3aad (patch)
tree91934c5e0990da6f4274476397d0aa9b18ba1758 /recipes-demo-hmi/navigation/mapviewer_%.bbappend
parentfb92e316727a1ad0012ac90ed52c5d9cecdcf433 (diff)
Add switch on/off script for cluster demo
v2.0: (Tadao Tanikawa) Completely rebuilt. The mapviewer and mapvier-demo are installed into porter's image only because they need AGL CES2017 Demo mock-up. To enable mapviewer-demo, execute switch_on_mapviewer-demo.sh at /usr/AGL/mapviewer-demo then reboot porter. CAUTION: After enabling mapviewer-demo, without cluster mock up which connected directly to porter board, weston on the porter board would always crash immediately after booting. If you fall into that situation, disable mapviewer-demo following instructions below. To disable mapviewer-demo, execute switch_off_mapviewer-demo.sh at /usr/AGL/mapviewer-demo then reboot porter. v1.0: (Yusuke Nakamura) This addes script to enable/disable CES2017 cluster demo to /usr/AGL/cluster-demo. Once switch_on_cluster-demo.sh is executed, this enables a service for cluster demo and sets configurations for the dmeo. Change-Id: Ie10f35ff4168095c3b3c6572579a2c4799c04578 Signed-off-by: ynakamura <ynakamura@jp.adit-jv.com> Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'recipes-demo-hmi/navigation/mapviewer_%.bbappend')
-rw-r--r--recipes-demo-hmi/navigation/mapviewer_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer_%.bbappend b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
index 3049a6741..a4eebfb4f 100644
--- a/recipes-demo-hmi/navigation/mapviewer_%.bbappend
+++ b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
@@ -1,6 +1,7 @@
FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
+ file://mapviewer-settings.sh \
file://mapviewer.service \
"
@@ -9,12 +10,22 @@ inherit systemd
SYSTEMD_PACKAGES = "${PN}"
do_install_append() {
+ install -d ${D}/usr/AGL/${PN}
+ install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}/usr/AGL/${PN}/
+
# Install systemd unit files
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
fi
}
+## DO NOT ENABLE 'weston-mapviewer-demo.service' BY DEFAULT
+##
+## This should be enabled/disabled by 'switch_on_mapviewer-demo.sh'/'switch_off_mapviewer-demo.sh'.
+##
+#SYSTEMD_SERVICE_${PN} = "mapviewer.service"
+
FILES_${PN} += " \
${systemd_system_unitdir}/mapviewer.service \
+ /usr/AGL/mapviewer/ \
"