summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-08 11:15:02 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:58:05 +0000
commit41591d4f8c586aa801220fac0924556f406c58bd (patch)
tree85a2803d48a094fb0ba3a76b9e3d0870a4e5edc2 /recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
parent4830bcef14e7f49cdc851c646a69c9bb9bd92e82 (diff)
SPEC-3723: restructure meta-agl-demo
All demo related components should be in here now. We keep the packagegroups on purpose for now to stay backward-compatible. v2: layer does pass yocto-check-layer, dependencies adapted v3: remove the dynamic-layer setup, use all-in-one approach v4: Fixed comments from Paul Barker. Tnx! v5: Removed wayland/weston/agl-compositor additions, except for demo specific weston-init bbappend Follow-up changes required later: - massaging packagegroups - scrub of recipes Bug-AGL: SPEC-3723 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I47cefd8c23d46b2cdd063470e3f7d97d5ad952d8
Diffstat (limited to 'recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb')
-rw-r--r--recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb21
1 files changed, 0 insertions, 21 deletions
diff --git a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
deleted file mode 100644
index d353d7dd..00000000
--- a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "AGL Reference POI application API key."
-DESCRIPTION = "Preload the API key for the AGL POI application."
-HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
-SECTION = "apps"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-
-inherit allarch
-
-do_fetch[noexec] = "1"
-do_unpack[noexec] = "1"
-do_compile[noexec] = "1"
-
-POIAPP_CLIENT_ID ?= ""
-POIAPP_API_KEY ?= ""
-
-do_install () {
- install -d ${D}${sysconfdir}
- echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
- echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
-}