summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/phone/phone_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-03-01 11:05:33 -0500
committerScott Murray <scott.murray@konsulko.com>2017-03-01 11:05:33 -0500
commit9d13096870330ac11d915893c113d9e25989153c (patch)
treef668477f19cb9b0cef3d81d9f0cb249ef5a81a9e /recipes-demo-hmi/phone/phone_git.bb
parent5f52a2cf2a739ab14c74d54f383e527a2c3676b9 (diff)
Switch to split out demo apps
Add recipes for the split out controls, dashboard, phone, and radio app repositories, remove the related packaging of same from the CES2017-demo recipe, and add the split out apps to IMAGE_AGL_APPS in the agl-demo-platform image definition. Bug-AGL: SPEC-400, SPEC-401, SPEC-402, SPEC-403, SPEC-404 Change-Id: I790eee4edf97ab9c32ddfe5fe277cb7f05012ffc Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/phone/phone_git.bb')
-rw-r--r--recipes-demo-hmi/phone/phone_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-demo-hmi/phone/phone_git.bb b/recipes-demo-hmi/phone/phone_git.bb
new file mode 100644
index 00000000..bff08434
--- /dev/null
+++ b/recipes-demo-hmi/phone/phone_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Phone for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating phone on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/phone"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=http"
+SRCREV = "${AUTOREV}"
+
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=http;branch=chinook"
+SRCREV_chinook = "a87aaf9b9d8c3eeae0e9006e4c73d17d03a55b93"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2"
+
+inherit qmake5 aglwgt