summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-03-29 18:17:51 -0400
committerScott Murray <scott.murray@konsulko.com>2017-03-29 18:23:17 -0400
commitdfcf831dfc1c8420397dc3d9b3d7a8f2d80ff9be (patch)
treecb884e576917b23ad2840784f4b4073c42db5c2d /recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
parentfac2695a7bfb78a8a1b599925cfabe977d71ac98 (diff)
Use split out AGL QtQuickControls2 repositories
Replace usage of the CES2017 repository with the new split out qtquickcontrols2-agl and qtquickcontrols2-agl-style repositories containing the AGL demo custom widgets and style. Since the CES2017-demo recipe no longer serves a purpose, remove it now as well. Bug-AGL: SPEC-404, SPEC-462 Change-Id: I0c31ccfe45c8912da4589e38c2cb159975536aad Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb')
-rw-r--r--recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb b/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
new file mode 100644
index 00000000..094edf7b
--- /dev/null
+++ b/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL demo custom QtQuickControls2 widgets"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/src/qtquickcontrols2-agl"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=http"
+SRCREV = "${AUTOREV}"
+
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=http;branch=chinook"
+SRCREV_chinook = "a7ac743468f50d6d2e2c3bcd275adc53b7ac26b1"
+
+S = "${WORKDIR}/git/"
+
+inherit qmake5
+
+FILES_${PN} += "${OE_QMAKE_PATH_QML}/AGL/Demo/Controls/*"
+
+RDEPENDS_${PN} += " \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ qtsvg-plugins \
+"