summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/radio
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-03-01 11:05:33 -0500
committerScott Murray <scott.murray@konsulko.com>2017-03-01 11:05:33 -0500
commit9d13096870330ac11d915893c113d9e25989153c (patch)
treef668477f19cb9b0cef3d81d9f0cb249ef5a81a9e /recipes-demo-hmi/radio
parent5f52a2cf2a739ab14c74d54f383e527a2c3676b9 (diff)
Switch to split out demo apps
Add recipes for the split out controls, dashboard, phone, and radio app repositories, remove the related packaging of same from the CES2017-demo recipe, and add the split out apps to IMAGE_AGL_APPS in the agl-demo-platform image definition. Bug-AGL: SPEC-400, SPEC-401, SPEC-402, SPEC-403, SPEC-404 Change-Id: I790eee4edf97ab9c32ddfe5fe277cb7f05012ffc Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/radio')
-rw-r--r--recipes-demo-hmi/radio/files/presets-ALS.conf12
-rw-r--r--recipes-demo-hmi/radio/files/presets-CES.conf14
-rw-r--r--recipes-demo-hmi/radio/files/presets-FOSDEM.conf14
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb48
4 files changed, 88 insertions, 0 deletions
diff --git a/recipes-demo-hmi/radio/files/presets-ALS.conf b/recipes-demo-hmi/radio/files/presets-ALS.conf
new file mode 100644
index 00000000..ff559227
--- /dev/null
+++ b/recipes-demo-hmi/radio/files/presets-ALS.conf
@@ -0,0 +1,12 @@
+[fmPresets]
+1\frequency=76100000
+1\title=Inter FM
+2\frequency=77100000
+2\title=The Open University of Japan
+3\frequency=80000000
+3\title=TOKYO FM
+4\frequency=81300000
+4\title=J-WAVE
+5\frequency=82500000
+5\title=NHK FM Tokyo
+size=5
diff --git a/recipes-demo-hmi/radio/files/presets-CES.conf b/recipes-demo-hmi/radio/files/presets-CES.conf
new file mode 100644
index 00000000..83caeffe
--- /dev/null
+++ b/recipes-demo-hmi/radio/files/presets-CES.conf
@@ -0,0 +1,14 @@
+[fmPresets]
+1\frequency=93100000
+1\title=93.1 The Mountain
+2\frequency=94100000
+2\title=Mix 94.1
+3\frequency=96300000
+3\title=96.3 KKLZ
+4\frequency=102700000
+4\title=102.7 THE COYOTE
+5\frequency=88900000
+5\title=News 88.9
+6\frequency=91500000
+6\title=KUNV
+size=6
diff --git a/recipes-demo-hmi/radio/files/presets-FOSDEM.conf b/recipes-demo-hmi/radio/files/presets-FOSDEM.conf
new file mode 100644
index 00000000..b88364f7
--- /dev/null
+++ b/recipes-demo-hmi/radio/files/presets-FOSDEM.conf
@@ -0,0 +1,14 @@
+[fmPresets]
+1\frequency=92100000
+1\title=92.1 Radio Campus
+2\frequency=92500000
+2\title=92.5 RTBF La Première
+3\frequency=93200000
+3\title=93.2 RTBF Classic 21
+4\frequency=98800000
+4\title=98.8 FM Brussel
+5\frequency=103700000
+5\title=103.7 NRJ
+6\frequency=104000000
+6\title=104.0 Bel RTL
+size=6
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
new file mode 100644
index 00000000..d48ba692
--- /dev/null
+++ b/recipes-demo-hmi/radio/radio_git.bb
@@ -0,0 +1,48 @@
+SUMMARY = "Radio for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating Radio on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/radio"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI_BRANCH = "master"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=http;branch=${SRC_URI_BRANCH} \
+ file://presets-ALS.conf \
+ file://presets-CES.conf \
+ file://presets-FOSDEM.conf \
+"
+SRCREV = "${AUTOREV}"
+
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_BRANCH_chinook = "chinook"
+SRCREV_chinook = "4dd6163184a243f80d6324c61d674383e88e9ba5"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 qtmultimedia"
+
+inherit qmake5 aglwgt
+
+# ALS, CES, FOSDEM available
+AGL_RADIO_PRESETS_LOCALE ?= "CES"
+
+do_install_append() {
+ install -d ${D}/home/root/app-data/radio
+ install -m 0644 ${WORKDIR}/presets-CES.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
+}
+
+FILES_${PN} += " \
+ /home/root/app-data/radio/presets-*.conf \
+ /home/root/app-data/radio/presets.conf \
+"
+
+RDEPENDS_${PN} += " \
+ qtmultimedia-qmlplugins \
+ qtmultimedia-rtlfm-radio-plugin \
+"