aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/settings/settings_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-12-29 18:51:16 -0500
committerScott Murray <scott.murray@konsulko.com>2019-12-29 18:51:16 -0500
commit0af7702519b7106a7775497475e3e57bea62a363 (patch)
tree33e69b4b8bb0e5f9c94d5e0f7eb9f14f2f1dc844 /recipes-demo-hmi/settings/settings_git.bb
parent0be8a1ddb505354f6ab028f2af359674211c0273 (diff)
Add qt-qrcode recipe for use in settings app
Add a recipe for the qt-qrcode libqrencode wrapper library to allow using it to display QR codes in the settings app, and update the settings app dependencies to add it as a dependency. As cleanup, the qtwebsockets dependency has been dropped from settings since it no longer requires it. Bug-AGL: SPEC-2981 Change-Id: Ia0d40ea1151765fa967457bf2ab6624dc7bc259d Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/settings/settings_git.bb')
-rw-r--r--recipes-demo-hmi/settings/settings_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-demo-hmi/settings/settings_git.bb b/recipes-demo-hmi/settings/settings_git.bb
index 36040823..72e0323f 100644
--- a/recipes-demo-hmi/settings/settings_git.bb
+++ b/recipes-demo-hmi/settings/settings_git.bb
@@ -13,12 +13,14 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "libqtappfw qtquickcontrols2 qtwebsockets"
+DEPENDS += "libqtappfw qtquickcontrols2 qt-qrcode"
DEPENDS += "libhomescreen qlibwindowmanager qtvirtualkeyboard"
# runtime dependencies
RDEPENDS_${PN} += " \
- agl-service-bluetooth \
- agl-service-network"
+ qt-qrcode \
+ agl-service-bluetooth \
+ agl-service-network \
+"
inherit qmake5 aglwgt