aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2016-12-22 21:28:35 +0900
committerNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2016-12-22 21:28:35 +0900
commite8b0dc607cff90d8a66d6172a3501698bd71ffa1 (patch)
tree0644cd34b7f77bec076225e7a36c098f71ba478b /recipes-demo-hmi
parent14377d440e00bcb2058acde6b585ca8029f709af (diff)
Add POI application
This patch adds a POI application to the AGL Distro. This patch includes provisional bug avoidance. Change-Id: Ib32b896428ac4a64d9a2c815cdeb6ab8c40d6c59 Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/navigation/poiapp/config.xml12
-rw-r--r--recipes-demo-hmi/navigation/poiapp/installNaviApps.sh6
-rw-r--r--recipes-demo-hmi/navigation/poiapp_git.bb31
3 files changed, 49 insertions, 0 deletions
diff --git a/recipes-demo-hmi/navigation/poiapp/config.xml b/recipes-demo-hmi/navigation/poiapp/config.xml
new file mode 100644
index 00000000..2f387db6
--- /dev/null
+++ b/recipes-demo-hmi/navigation/poiapp/config.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<widget xmlns="http://www.w3.org/ns/widgets" id="poi" version="0.1">
+ <name>POI</name>
+ <icon src="poi.png"/>
+ <content src="poi" type="application/x-executable"/>
+ <description>POI App</description>
+ <author>AISIN AW</author>
+ <feature name="urn:AGL:required-permission">
+ <param name="http://tizen.org/privilege/internal/dbus" value="required" />
+ </feature>
+ <license>GPL</license>
+</widget>
diff --git a/recipes-demo-hmi/navigation/poiapp/installNaviApps.sh b/recipes-demo-hmi/navigation/poiapp/installNaviApps.sh
new file mode 100644
index 00000000..50f27d69
--- /dev/null
+++ b/recipes-demo-hmi/navigation/poiapp/installNaviApps.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+/usr/bin/afm-util install poi.wgt
+
+#it's Workaround
+cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus'
+cyad -s -k MANIFESTS -t allow -c User::App::poi -u '*' -p 'http://tizen.org/privilege/internal/dbus'
diff --git a/recipes-demo-hmi/navigation/poiapp_git.bb b/recipes-demo-hmi/navigation/poiapp_git.bb
new file mode 100644
index 00000000..45753660
--- /dev/null
+++ b/recipes-demo-hmi/navigation/poiapp_git.bb
@@ -0,0 +1,31 @@
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM="file://LICENSE;md5=53633740548e7211116fc17bbe20aaf8"
+
+inherit cmake_qt5 pkgconfig
+
+DEPENDS += " qtbase libdbus-c++ json-c \
+ "
+
+SRCREV="4e09ab88d0d97c59896ba66bf08a8e006e2af81a"
+SRC_URI="git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=new-layout \
+ file://config.xml \
+ file://installNaviApps.sh \
+"
+
+RDEPENDS_${PN} = " navigation "
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ mkdir -p ${WORKDIR}/widget
+ install -m 0644 ${WORKDIR}/config.xml ${WORKDIR}/widget
+ install -m 0755 ${D}/usr/bin/yelp-client ${WORKDIR}/widget/poi
+ zip -ju ${WORKDIR}/widget/poi.wgt ${WORKDIR}/widget/poi ${WORKDIR}/widget/config.xml
+
+ install -d ${D}/usr/AGL/ces2017-demo
+ install -m 0644 ${WORKDIR}/widget/poi.wgt ${D}/usr/AGL/ces2017-demo/
+
+ install -m 0755 ${WORKDIR}/installNaviApps.sh ${D}/usr/AGL/ces2017-demo/
+}
+
+FILES_${PN} += " /usr/AGL/ces2017-demo/poi.wgt /usr/AGL/ces2017-demo/installNaviApps.sh "