summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-28 16:00:58 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-28 18:20:57 +0900
commitbeb8cd9b20f3010e117c428d7ba3f15d80e5a310 (patch)
tree69f33a1d01a7e7c7c9370237f8f951dae20c44bc /recipes-demo-hmi
parent37ec716cf239a5d98712d0693be00662c826831c (diff)
Refactor wgt package installation
To fix missing installatioin of mediaplayer.wgt and support additional wgt packages in future, refactor installation script to install whole apps under /usr/AGL/apps. And adding 'sync' because sometimes apps broken if reboot immediately after installing apps. Change-Id: I69f0761439d421b5656b89bce72df1d59dad3c18 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index 49f5c3e6..e66a9600 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -92,14 +92,11 @@ do_install_prepend() {
cat > ${B}/apps/installAllApps.sh <<-EOF
#!/bin/sh
cd /usr/AGL/apps
- /usr/bin/afm-util install controls.wgt
- /usr/bin/afm-util install dashboard.wgt
- /usr/bin/afm-util install phone.wgt
- /usr/bin/afm-util install radio.wgt
- /usr/bin/afm-util install settings.wgt
- /usr/bin/afm-util install navigation.wgt
- /usr/bin/afm-util install poi.wgt
- /usr/bin/afm-util install mixer.wgt
+ for file in \`find . -maxdepth 1 -name '*.wgt'\`; do
+
+ /usr/bin/afm-util install \$file
+ done
+ sync
#it's Workaround
cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus'