summaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-02-06 19:03:29 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-07 14:57:14 +0000
commit2e014bfbd0757f2e35559543ba78d95cbc88b2c5 (patch)
treeb219a82002a0c17ebc4f7636f4e0bc368c2aa8e2 /recipes-demo-hmi
parent5000d2e090cc2c8df74a7a96804882e8e74d9bdf (diff)
html5-dashboard: create recipe and add to html5 demo
Bug-AGL: SPEC-3151 Change-Id: Iee5fcba63de56f7d326a9015902f63e4d48632bf Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
Diffstat (limited to 'recipes-demo-hmi')
-rw-r--r--recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
new file mode 100644
index 000000000..534bd2d38
--- /dev/null
+++ b/recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 dashboard Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-dashboard/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}
Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
From 7baf674a7c54d3241d796adf3249b304aa2aeaaf Mon Sep 17 00:00:00 2001
From: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
Date: Mon, 14 Jul 2014 11:44:41 +0900
Subject: [PATCH] arm: shmobile: alt: Add 'vmalloc=384M' to bootargs of DTS

Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
---
 arch/arm/boot/dts/r8a7794-alt.dts |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/arm/boot/dts/r8a7794-alt.dts b/arch/arm/boot/dts/r8a7794-alt.dts
index 3e1afef..c85edda8 100644
--- a/arch/arm/boot/dts/r8a7794-alt.dts
+++ b/arch/arm/boot/dts/r8a7794-alt.dts
@@ -31,7 +31,7 @@
 	compatible = "renesas,alt", "renesas,r8a7794";
 
 	chosen {
-		bootargs = "console=ttySC10,38400 ignore_loglevel rw root=/dev/nfs ip=dhcp";
+		bootargs = "console=ttySC10,38400 ignore_loglevel rw root=/dev/nfs ip=dhcp vmalloc=384M";
 	};
 
 	memory@40000000 {
-- 
1.7.9.5