aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-17 20:36:07 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-17 20:36:07 -0400
commit3629f087c22c65265e1271cb649edf9e89e53a75 (patch)
treecc41306e95ef111727b30926b77f3ff6a157d8dc /recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
parent5fdeddef62f6873e0cc726c73760fe9fb8d57b36 (diff)
agl-service-audiomixer: add updated recipe
Add recipes to build the new incarnation of VIS client daemon version of agl-service-audiomixer that will serve as the base for future API development. As well, add the new package to the appropriate packagegroup. Bug-AGL: SPEC-4409 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2f433aab8dd2113e1d6bf6914ce18155261b8c7f
Diffstat (limited to 'recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb')
-rw-r--r--recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
new file mode 100644
index 00000000..d3e07646
--- /dev/null
+++ b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Audio Mixer Service Daemon"
+DESCRIPTION = "AGL Audio Mixer Service Daemon"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-audiomixer"
+SECTION = "apps"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;beginline=3;md5=e8ad01a5182f2c1b3a2640e9ea268264"
+
+DEPENDS = "boost openssl nlohmann-json systemd pipewire wireplumber"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-audiomixer.git;protocol=https;branch=${AGL_BRANCH} \
+ file://agl-service-audiomixer.conf \
+ file://agl-service-audiomixer.token \
+"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "2.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN} = "agl-service-audiomixer.service"
+
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer
+ install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/agl-service-audiomixer.token ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "kuksa-val"