summaryrefslogtreecommitdiffstats
path: root/recipes-demo/agl-service-audiomixer
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-17 20:36:07 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-17 20:36:07 -0400
commit3629f087c22c65265e1271cb649edf9e89e53a75 (patch)
treecc41306e95ef111727b30926b77f3ff6a157d8dc /recipes-demo/agl-service-audiomixer
parent5fdeddef62f6873e0cc726c73760fe9fb8d57b36 (diff)
agl-service-audiomixer: add updated recipe
Add recipes to build the new incarnation of VIS client daemon version of agl-service-audiomixer that will serve as the base for future API development. As well, add the new package to the appropriate packagegroup. Bug-AGL: SPEC-4409 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2f433aab8dd2113e1d6bf6914ce18155261b8c7f
Diffstat (limited to 'recipes-demo/agl-service-audiomixer')
-rw-r--r--recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf2
-rw-r--r--recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.token1
-rw-r--r--recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb38
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf
new file mode 100644
index 00000000..6bf92de5
--- /dev/null
+++ b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/agl-service-audiomixer/agl-service-audiomixer.token"
diff --git a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.token b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
new file mode 100644
index 00000000..d3e07646
--- /dev/null
+++ b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Audio Mixer Service Daemon"
+DESCRIPTION = "AGL Audio Mixer Service Daemon"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-audiomixer"
+SECTION = "apps"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;beginline=3;md5=e8ad01a5182f2c1b3a2640e9ea268264"
+
+DEPENDS = "boost openssl nlohmann-json systemd pipewire wireplumber"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-audiomixer.git;protocol=https;branch=${AGL_BRANCH} \
+ file://agl-service-audiomixer.conf \
+ file://agl-service-audiomixer.token \
+"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "2.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN} = "agl-service-audiomixer.service"
+
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer
+ install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/agl-service-audiomixer.token ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "kuksa-val"