summaryrefslogtreecommitdiffstats
path: root/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-16 00:48:55 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-16 00:51:36 -0400
commit1bc8975efe0a725124c0780ae4aabd3259511fb2 (patch)
tree99105f986f48c67fd64bf1cbc5c5c9f30b166ffe /recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb
parentea285aba8248385a841b7f4feb1b41b2f506407d (diff)
agl-service-hvac: add updated recipes
Add recipes to build the new incarnation of VIS client daemon version of agl-service-hvac and for installing associated demo platform configuration files for the full AGL demo setup. As well, add the new packages from these recipes to the appropriate packagegroups. Bug-AGL: SPEC-4409 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ifeee032e19349f8e780c05f0e8c8cf11fc635452
Diffstat (limited to 'recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb')
-rw-r--r--recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb b/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb
new file mode 100644
index 00000000..75987905
--- /dev/null
+++ b/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb
@@ -0,0 +1,31 @@
+SUMMARY = "AGL demo configuration for HVAC service daemon"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-hvac"
+SECTION = "apps"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://agl-service-hvac-can.conf.demo \
+ file://sllin.conf \
+"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install () {
+ # Install configuration file to use sllin0 instead of the default
+ # can0 CAN device.
+ install -D -m 644 ${WORKDIR}/agl-service-hvac-can.conf.demo ${D}${sysconfdir}/xdg/AGL/agl-service-hvac-can.conf
+
+ # Install systemd override to add a dependency on kuksa-dbc-feeder-sllin.service,
+ # which currently brings up sllin0. This will need to be reworked in the future
+ # to be a bit more straightforward.
+ install -d ${D}${systemd_system_unitdir}/agl-service-hvac.service.d
+ install -m 0644 ${WORKDIR}/sllin.conf ${D}${systemd_system_unitdir}/agl-service-hvac.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "agl-service-hvac kuksa-dbc-feeder-sllin"