summaryrefslogtreecommitdiffstats
path: root/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-16 00:48:55 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-16 00:51:36 -0400
commit1bc8975efe0a725124c0780ae4aabd3259511fb2 (patch)
tree99105f986f48c67fd64bf1cbc5c5c9f30b166ffe /recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
parentea285aba8248385a841b7f4feb1b41b2f506407d (diff)
agl-service-hvac: add updated recipes
Add recipes to build the new incarnation of VIS client daemon version of agl-service-hvac and for installing associated demo platform configuration files for the full AGL demo setup. As well, add the new packages from these recipes to the appropriate packagegroups. Bug-AGL: SPEC-4409 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ifeee032e19349f8e780c05f0e8c8cf11fc635452
Diffstat (limited to 'recipes-demo/agl-service-hvac/agl-service-hvac_git.bb')
-rw-r--r--recipes-demo/agl-service-hvac/agl-service-hvac_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb b/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
new file mode 100644
index 00000000..b8864337
--- /dev/null
+++ b/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Demo HVAC Service Daemon"
+DESCRIPTION = "Demo HVAC Service Daemon"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-hvac"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "boost openssl nlohmann-json systemd"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-hvac;protocol=https;branch=${AGL_BRANCH} \
+ file://agl-service-hvac.conf \
+ file://agl-service-hvac.token \
+"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "2.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN} = "agl-service-hvac.service"
+
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/agl-service-hvac
+ install -m 0644 ${WORKDIR}/agl-service-hvac.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/agl-service-hvac.token ${D}${sysconfdir}/xdg/AGL/agl-service-hvac/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "kuksa-val"