summaryrefslogtreecommitdiffstats
path: root/recipes-demo/agl-service-radio
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-02-20 15:17:17 -0500
committerScott Murray <scott.murray@konsulko.com>2024-03-19 14:10:19 +0000
commita048283b5d63452f1a752769a690b53ef884e70f (patch)
tree724bea2d0c5cc4ead366c8fa967f4605293f2a2e /recipes-demo/agl-service-radio
parentcdb8cbef1ff2bbf188918f7d5a37763b57873f66 (diff)
Enable running audio services on host for KVM demo
Changes: - Add agl-kvm-host-audio feature for configuring other changes. - Make installation of packagegroup-agl-ivi-service-platform in the KVM host versus IVI images dependent on the agl-kvm-host-audio feature. Some recipe dependencies are tweaked by the feature being specified to avoid accidentally pulling things into the IVI guest images. - Add KVM demo specific configuration for applications affected by running the databroker on the host versus in the IVI guest, and use it if the agl-kvm-host-kuksa feature is enabled. Bug-AGL: SPEC-5082 Change-Id: I3a6e6216a90e4d260c20f0b048e6332466aef4ff Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29702 ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account (cherry picked from commit 49a85681e52d1f568a5bb6086d7e14af701ac6dc) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29762
Diffstat (limited to 'recipes-demo/agl-service-radio')
-rw-r--r--recipes-demo/agl-service-radio/agl-service-radio_git.bb19
-rw-r--r--recipes-demo/agl-service-radio/files/radio.conf.kvm-demo2
2 files changed, 20 insertions, 1 deletions
diff --git a/recipes-demo/agl-service-radio/agl-service-radio_git.bb b/recipes-demo/agl-service-radio/agl-service-radio_git.bb
index 7664e5ab..89c18ae7 100644
--- a/recipes-demo/agl-service-radio/agl-service-radio_git.bb
+++ b/recipes-demo/agl-service-radio/agl-service-radio_git.bb
@@ -17,7 +17,8 @@ DEPENDS = " \
libusb-compat \
"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH} \
+ file://radio.conf.kvm-demo"
SRCREV = "7f26a2d06410fd3a2768612b9c9daf869778e480"
PV = "2.0+git${SRCPV}"
@@ -27,4 +28,20 @@ inherit meson pkgconfig systemd
SYSTEMD_SERVICE:${PN} = "agl-service-radio.service"
+do_install:append() {
+ install -D -m 0644 ${WORKDIR}/radio.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL.conf
+}
+
+PACKAGE_BEFORE_PN += "${PN}-conf-kvm-demo"
+
FILES:${PN} += "${systemd_system_unitdir}"
+
+FILES:${PN}-conf-kvm-demo += " \
+ ${sysconfdir}/xdg/AGL.conf \
+"
+
+RDEPENDS:${PN} += " \
+ gstreamer1.0 \
+ gstreamer1.0-plugins-base \
+ gstreamer1.0-pipewire \
+"
diff --git a/recipes-demo/agl-service-radio/files/radio.conf.kvm-demo b/recipes-demo/agl-service-radio/files/radio.conf.kvm-demo
new file mode 100644
index 00000000..d855eb4b
--- /dev/null
+++ b/recipes-demo/agl-service-radio/files/radio.conf.kvm-demo
@@ -0,0 +1,2 @@
+[radio]
+bind=0.0.0.0