summaryrefslogtreecommitdiffstats
path: root/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-18 20:40:31 -0500
committerScott Murray <scott.murray@konsulko.com>2023-01-19 15:34:12 -0500
commit5109016c566a4a46e4a85f2c7b9dfcd6b8540233 (patch)
tree583e0da3d6df24580e86285b0d727c86c9dd36a4 /recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
parent0eb0e7ad872bc03cbc8af5c95bfe0219ebf06bfd (diff)
Make cluster dashboard KUKSA.val server configurable
Add CLUSTER_DEMO_VISS_HOSTNAME variables to the cluster-dashboard and flutter-cluster-dashboard recipes and tweak the installed configuration files to use the address it specifies. This provides a hook for tweaking the configuration for e.g. running in the guest VMs in the QEMU+KVM demo. This may need to be tweaked down the road to use something like multiple packages + the alternatives mechanism instead. Bug-AGL: SPEC-4618 Change-Id: I101b2c966fc2923a5f4946ea1c5e95695061c041 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo/cluster-dashboard/cluster-dashboard_git.bb')
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index 254c4013..b51c581d 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -28,6 +28,8 @@ S = "${WORKDIR}/git"
inherit pkgconfig cmake_qt5
+CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
+
do_install:append() {
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
@@ -39,6 +41,7 @@ do_install:append() {
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
install -m 0644 ${WORKDIR}/cluster-dashboard.conf ${D}${sysconfdir}/xdg/AGL/
+ sed -i "s/^server = .*/server = \"${CLUSTER_DEMO_VISS_HOSTNAME}\"/" ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.conf
install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}