summaryrefslogtreecommitdiffstats
path: root/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-08-15 15:39:21 -0400
committerScott Murray <scott.murray@konsulko.com>2024-08-20 14:21:56 +0000
commit145d8b075a26f9b8810c6b846642db63b462ea38 (patch)
treed14310dabde5557a5db81f1be9e48f9a42ac2f06 /recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
parentd3856bff8cfc0552eb51d4bf0d4ce72a4d13d4c9 (diff)
Fix Qt cluster demo images
The rework of the demo images done for SPEC-5138 missed some things for the Qt cluster demo images, so add the extra demo vs non-demo configuration file for use in the "preconfigured" image, and update the image recipes to get things work with respect to developer expecations. Additionally: - The databroker access token for cluster-dashboard was out of date, a copy of the one for the Flutter cluster dashboard has been copied in to restore expected behavior. - The Flutter cluster demo has also been tweaked slightly to match the style used in the other image recipes. Bug-AGL: SPEC-5229 Change-Id: I8cc9cfb67c31ace95e6ac36e4259099223f7d802 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30174 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Naoto YAMAGUCHI <naoto.yamaguchi@aisin.co.jp> (cherry picked from commit 4f0351ed75b5d7384e0e5ec2d6621610d6e51c1a) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30202
Diffstat (limited to 'recipes-demo/cluster-dashboard/cluster-dashboard_git.bb')
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb27
1 files changed, 23 insertions, 4 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index dd0e411a3..6c33d159d 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -19,14 +19,15 @@ PV = "1.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-dashboard;protocol=https;branch=${AGL_BRANCH} \
file://cluster-dashboard.service \
- file://cluster-dashboard.conf \
+ file://cluster-dashboard.conf.default \
+ file://cluster-dashboard.conf.demo \
file://cluster-dashboard.token \
"
SRCREV = "137144c447d8adb618f5acbcbafd65f50264d6eb"
S = "${WORKDIR}/git"
-inherit pkgconfig cmake_qt5 systemd
+inherit pkgconfig cmake_qt5 update-alternatives systemd
CLUSTER_DEMO_VSS_HOSTNAME ??= "192.168.10.2"
@@ -40,11 +41,29 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
- install -m 0644 ${WORKDIR}/cluster-dashboard.conf ${D}${sysconfdir}/xdg/AGL/
- sed -i "s/^server = .*/server = \"${CLUSTER_DEMO_VSS_HOSTNAME}\"/" ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.conf
+ install -m 0644 ${WORKDIR}/cluster-dashboard.conf.default ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/cluster-dashboard.conf.demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
+ALTERNATIVE_LINK_NAME[cluster-dashboard.conf] = "${sysconfdir}/xdg/AGL/cluster-dashboard.conf"
+
+PACKAGE_BEFORE_PN += "${PN}-conf"
+FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/cluster-dashboard.conf.default"
+RDEPENDS:${PN}-conf = "${PN}"
+RPROVIDES:${PN}-conf = "cluster-dashboard.conf"
+ALTERNATIVE:${PN}-conf = "cluster-dashboard.conf"
+ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/cluster-dashboard.conf.default"
+
+PACKAGE_BEFORE_PN += "${PN}-conf-demo"
+FILES:${PN}-conf-demo += "${sysconfdir}/xdg/AGL/cluster-dashboard.conf.demo"
+RDEPENDS:${PN}-conf-demo = "${PN}"
+RPROVIDES:${PN}-conf-demo = "cluster-dashboard.conf"
+ALTERNATIVE:${PN}-conf-demo = "cluster-dashboard.conf"
+ALTERNATIVE_TARGET_${PN}-conf-demo = "${sysconfdir}/xdg/AGL/cluster-dashboard.conf.demo"
+
+# NOTE: Not currently used in KVM demo, so no extra configurations packaged here
+
RDEPENDS:${PN} += " \
qtwayland \
qtbase-qmlplugins \