summaryrefslogtreecommitdiffstats
path: root/recipes-demo/cluster-dashboard
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-03-07 16:21:05 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-03-08 14:49:45 +0000
commit6cce1d8fcff72bd429a6f0aea23fc5666fd67878 (patch)
tree3d9992258a8877afcc5bb90a0def2706a83816ab /recipes-demo/cluster-dashboard
parent8e02ea4d58b42e6d1bad629399b25713e34e55e9 (diff)
Restore cluster and telematics demo images
Changes: - Restore the image recipes for the agl-cluster-demo-platform and agl-telematics-demo-platform images, with updates to them and their associated packagegroups for the app framework removal. - Restore updated recipes required for the above, including: * cluster-dashboard * cluster-receiver * qt-cluster-receiver * tbtnavi - Simple systemd unit files have been added for the cluster applications and are installed as user session units. Starting of cluster-dashboard (the XDG version) and cluster-receiver in the AGL user session is enabled by default. - The recipes to install the dedicated network configuration for the cluster demo have been restored so that the agl-cluster-demo-support and agl-demo-preload features will do what is expected again. Known outstanding issues: - The previous signal-composer binding support has been removed from cluster-dashboard, so related functionality (i.e. driving it from CAN) is disabled until replacement is worked out. - While tbtnavi builds, the previous use of the navigation binding is stubbed out in libqtappfw, so it will not receive location and route information from ondemandnavi. - Nothing has been added yet to start tbtnavi in the AGL user session, the plan is to do so with a systemd user unit once a new mechanism for controlling it from ondemandnavi has been implemented. - The telematics-recorder application has not yet been updated to replace its signal-composer, gps, and network binding use. The intent is to address these issues in the 13.0.x point releases. Bug-AGL: SPEC-4283 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I520c23775b21504cb7dd92538319cc5bf826ff64
Diffstat (limited to 'recipes-demo/cluster-dashboard')
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service20
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb46
2 files changed, 66 insertions, 0 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service
new file mode 100644
index 00000000..d96c738b
--- /dev/null
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.service
@@ -0,0 +1,20 @@
+[Unit]
+Description=cluster-dashboard
+
+Requires=agl-compositor.service
+After=agl-compositor.service
+
+# Since we are part of the agl session, make sure we are started before
+# it is complete.
+Before=agl-session.target
+
+[Service]
+ExecStart=/usr/bin/cluster-dashboard
+
+Restart=always
+
+StandardOutput=journal
+StandardError=journal
+
+[Install]
+WantedBy=agl-session.target
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
new file mode 100644
index 00000000..2f5bbecf
--- /dev/null
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Instrument Cluster Dashboard application"
+DESCRIPTION = "AGL demonstration instrument cluster dashboard application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-dashboard"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+ file://app/cluster-gauges.qml;beginline=9;endline=48;md5=54187d50b29429abee6095fe8b7c1a78"
+
+DEPENDS = " \
+ qtquickcontrols2 \
+ libqtappfw \
+ glib-2.0 \
+ wayland wayland-native \
+ qtwayland qtwayland-native \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-dashboard;protocol=https;branch=${AGL_BRANCH} \
+ file://cluster-dashboard.service \
+"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig cmake_qt5
+
+do_install:append() {
+ install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+ install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
+ ln -s ../${BPN}.service ${D}${systemd_user_unitdir}/agl-session.target.wants/${BPN}.service
+}
+
+FILES:${PN} += " ${systemd_user_unitdir}"
+
+RDEPENDS:${PN} += " \
+ qtwayland \
+ qtbase-qmlplugins \
+ qtquickcontrols \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2 \
+ qtquickcontrols2-qmlplugins \
+ qtgraphicaleffects-qmlplugins \
+ qtsvg-plugins \
+"