summaryrefslogtreecommitdiffstats
path: root/recipes-demo/cluster-dashboard
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerScott Murray <scott.murray@konsulko.com>2024-12-19 22:41:31 -0500
commitb8f5c41d1d447795ffa72e3ceeeaf12f6f0e1605 (patch)
tree7db11a20de9ca399678bbd8c12b70cdf394b85e4 /recipes-demo/cluster-dashboard
parentd100e89de22d6a950b3caab4d060b7e8dc3f4e15 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo/cluster-dashboard')
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index c5a56f434..d8a577bf1 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -34,16 +34,16 @@ CLUSTER_DEMO_VSS_HOSTNAME ??= "192.168.10.2"
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
# VIS authorization token file for KUKSA.val should ideally not
# be readable by other users, but currently that's not doable
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
- install -m 0644 ${WORKDIR}/cluster-dashboard.conf.default ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/cluster-dashboard.conf.demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.conf.default ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.conf.demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
ALTERNATIVE_LINK_NAME[cluster-dashboard.conf] = "${sysconfdir}/xdg/AGL/cluster-dashboard.conf"