summaryrefslogtreecommitdiffstats
path: root/recipes-demo/dashboard/dashboard_git.bb
diff options
context:
space:
mode:
authorIndivara Weerasuriya <indivara.weerasuriya@qt.io>2024-07-30 19:47:24 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-20 13:35:26 +0000
commit59ae0b13d2bb14fbf12117f2f55bfcb6f06f104b (patch)
treeba38354db9033675bde1ad07700d796160450f8f /recipes-demo/dashboard/dashboard_git.bb
parenta37e8ed0c8f997e13d719c7e5d956b5febc9cfa5 (diff)
Migrate demo app recipes and patch apps to Qt 6
Bug-AGL: SPEC-5294 Change-Id: I6b9ff940745f88af9a3b69e29917082e52b25f88 Signed-off-by: Indivara Weerasuriya <indivara.weerasuriya@qt.io> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30141 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-demo/dashboard/dashboard_git.bb')
-rw-r--r--recipes-demo/dashboard/dashboard_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-demo/dashboard/dashboard_git.bb b/recipes-demo/dashboard/dashboard_git.bb
index c0ca244cc..c4385400b 100644
--- a/recipes-demo/dashboard/dashboard_git.bb
+++ b/recipes-demo/dashboard/dashboard_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = " \
qttools-native \
- qtquickcontrols2 \
+ qtdeclarative \
libqtappfw \
"
@@ -17,12 +17,13 @@ PV = "2.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH} \
file://dashboard.conf \
file://dashboard.token \
-"
+ file://0001-Migrate-to-Qt-6.patch \
+ "
SRCREV = "b1b67ab525555a082ca257ad08fc4fba9b1f74e3"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig agl-app
+inherit qt6-qmake pkgconfig agl-app
AGL_APP_NAME = "Dashboard"
@@ -42,6 +43,6 @@ do_install:append() {
RDEPENDS:${PN} += " \
qtwayland \
qtbase-qmlplugins \
- qtgraphicaleffects-qmlplugins \
+ qt5compat \
qtquickcontrols2-agl-style \
"