summaryrefslogtreecommitdiffstats
path: root/recipes-demo/dashboard
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-07 16:12:25 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-06 14:32:43 -0400
commitfa8b62e148ec1f2be0494d6f899940913d49704f (patch)
treef96d057ef4744c5b45c61ac33ffbf340a122dc0c /recipes-demo/dashboard
parent074e2c5eb63cd7dafd9d48326c8fadb8da30e9b2 (diff)
Update vehicle signal using app recipes
Update the recipes for the Qt demo applications that were previously using signal-composer either directly or indirectly to work with the new VehicleSignals API in libqtappfw. For most of them this means updating their SRCREV to pick up the application changes, and installing the new configuration file and associated JSON web token file for KUKSA.val authorization. At present all the apps are using one of the default read-write tokens from the KUKSA.val install, but ideally this will end up migrated to app specific tokens with appropriate permissions JSON down the road, potentially obtained via OAuth or similar mechanism. Additionally, the tbtnavi recipe has been updated to install a systemd unit to start it at boot. Bug-AGL: SPEC-4409, SPEC-4426 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I46be098fc31be02852e7888ba0ffd14674efa12b
Diffstat (limited to 'recipes-demo/dashboard')
-rw-r--r--recipes-demo/dashboard/dashboard/dashboard.conf2
-rw-r--r--recipes-demo/dashboard/dashboard/dashboard.token1
-rw-r--r--recipes-demo/dashboard/dashboard_git.bb21
3 files changed, 22 insertions, 2 deletions
diff --git a/recipes-demo/dashboard/dashboard/dashboard.conf b/recipes-demo/dashboard/dashboard/dashboard.conf
new file mode 100644
index 00000000..23695db3
--- /dev/null
+++ b/recipes-demo/dashboard/dashboard/dashboard.conf
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/dashboard/dashboard.token"
diff --git a/recipes-demo/dashboard/dashboard/dashboard.token b/recipes-demo/dashboard/dashboard/dashboard.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/dashboard/dashboard/dashboard.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/dashboard/dashboard_git.bb b/recipes-demo/dashboard/dashboard_git.bb
index 509b68b2..9f5dba83 100644
--- a/recipes-demo/dashboard/dashboard_git.bb
+++ b/recipes-demo/dashboard/dashboard_git.bb
@@ -9,17 +9,34 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = " \
qttools-native \
qtquickcontrols2 \
+ libqtappfw \
"
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "3fc84a0a674fa532f6aded100cf2beb3d0cf1f83"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH} \
+ file://dashboard.conf \
+ file://dashboard.token \
+"
+SRCREV = "4efe67714e60e2ab86acf1edee500373f6820954"
S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/dashboard
+ install -m 0644 ${WORKDIR}/dashboard.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/dashboard.token ${D}${sysconfdir}/xdg/AGL/dashboard/
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += " \