summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
diff options
context:
space:
mode:
authorAakash Solanki <tech2aks@gmail.com>2022-08-06 13:49:55 +0200
committerAakash Solanki <tech2aks@gmail.com>2022-08-08 20:44:07 +0200
commitf8eb43810177a33d2fb414341e31caa0ae75bdfe (patch)
tree7ed6fedcb67834c57791da21b3a251fc5c59ace2 /recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
parent85d834afe1cdc9c25e3d94daefc8d515b7d0c361 (diff)
Update agl-cluster-demo-platform-flutter image
- Remove packagegroup and add packages to image - Add a script to set some value in Kuksa data model - Add Simple-CAN-simulator Bug-AGL: SPEC-4508 Change-Id: Ibf4f4c2b02f7860e2f93c08a5c0e064272652657 Signed-off-by: Aakash Solanki <tech2aks@gmail.com>
Diffstat (limited to 'recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb')
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb17
1 files changed, 1 insertions, 16 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index 5e903312..44be070f 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -30,16 +30,6 @@ APP_CONFIG = "ic_on_bg-release.json"
APP_CONFIG:class-runtimedebug = "ic_on_bg-debug.json"
APP_CONFIG:class-runtimeprofile = "ic_on_bg-profile.json"
-# To avoid conflicts with the systemd template scheme added via bbappend in
-# meta-agl-demo, package the standalone systemd unit separately. This is not
-# needed when meta-agl-flutter is used without meta-agl-demo, but that is not
-# going to be the default usecase for most users, so this still allows them to
-# build working agl-image-flutter images in the same build tree.
-#
-# This can be dropped if/when flutter-gallery is no longer packaged as a demo
-# in meta-agl-demo.
-
-#SYSTEMD_SERVICE:${PN}-init = "flutter-cluster-dashboard.service"
do_install:append() {
install -D -m 0644 ${WORKDIR}/flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/flutter-cluster-dashboard.service
@@ -49,10 +39,5 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/default.json
}
-PACKAGE_BEFORE_PN += "${PN}-init"
-
-FILES:${PN} += "${datadir}"
-
-FILES:${PN}-init = "${systemd_user_unitdir}"
-RDEPENDS:${PN}-init = "${PN}" \ No newline at end of file
+FILES:${PN} += "${datadir} ${systemd_user_unitdir}"