summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2023-05-31 18:37:12 -0700
committerScott Murray <scott.murray@konsulko.com>2023-06-01 19:00:13 -0400
commitde1dccae31b3c7c62f0e19102b7223d747f413ed (patch)
tree475006ad03e45aca7c5d456e8af3ee2795341596 /recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
parent72b82ba156081172f6d3638a1139980a094e87a0 (diff)
Flutter bbclass refactor
-Removes use of flutter bbclass runtime modes Installed modes are determined by flutter-engine package config flags. Default modes are debug, profile, and release. -Single json file based on runtime=release. If additional parameters are needed this happens as part of workspace automation. Scott Murray: - update packagegroup-agl-demo-platform-flutter Bug-AGL: SPEC-4819 Change-Id: I58fc1b30ea3367ec5f47f52b60951cf0be31dcbc Signed-off-by: Joel Winarske <joel.winarske@gmail.com> Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb')
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index a1dc29f6..2effcfed 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -10,9 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=0c52b0e4b5f0dbf57ea7d44bebb2e29d"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-cluster;protocol=https;branch=${AGL_BRANCH} \
file://flutter-cluster-dashboard.service \
- file://flutter_cluster_dashboard_on_bg-debug.json \
- file://flutter_cluster_dashboard_on_bg-profile.json \
- file://flutter_cluster_dashboard_on_bg-release.json \
+ file://flutter_cluster_dashboard_on_bg.json \
file://flutter-cluster-dashboard.yaml \
file://flutter-cluster-dashboard.yaml.demo \
"
@@ -32,9 +30,7 @@ inherit flutter-app update-alternatives
CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
-APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
-APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
-APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
+APP_CONFIG = "flutter_cluster_dashboard_on_bg.json"
do_install:append() {
install -D -m 0644 ${WORKDIR}/flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/flutter-cluster-dashboard.service