summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-cluster-dashboard
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-02-20 15:17:17 -0500
committerScott Murray <scott.murray@konsulko.com>2024-03-19 14:10:19 +0000
commita048283b5d63452f1a752769a690b53ef884e70f (patch)
tree724bea2d0c5cc4ead366c8fa967f4605293f2a2e /recipes-demo/flutter-cluster-dashboard
parentcdb8cbef1ff2bbf188918f7d5a37763b57873f66 (diff)
Enable running audio services on host for KVM demo
Changes: - Add agl-kvm-host-audio feature for configuring other changes. - Make installation of packagegroup-agl-ivi-service-platform in the KVM host versus IVI images dependent on the agl-kvm-host-audio feature. Some recipe dependencies are tweaked by the feature being specified to avoid accidentally pulling things into the IVI guest images. - Add KVM demo specific configuration for applications affected by running the databroker on the host versus in the IVI guest, and use it if the agl-kvm-host-kuksa feature is enabled. Bug-AGL: SPEC-5082 Change-Id: I3a6e6216a90e4d260c20f0b048e6332466aef4ff Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29702 ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account (cherry picked from commit 49a85681e52d1f568a5bb6086d7e14af701ac6dc) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29762
Diffstat (limited to 'recipes-demo/flutter-cluster-dashboard')
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.demo1
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/kvm.conf3
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb8
3 files changed, 11 insertions, 1 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.demo b/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.demo
index bab0a6bb..32545c2b 100644
--- a/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.demo
+++ b/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.demo
@@ -1,3 +1,4 @@
hostname: 192.168.10.2
authorization : "/etc/xdg/AGL/cluster-dashboard/cluster-dashboard.token"
use-tls : true
+tls-server-name : "localhost"
diff --git a/recipes-demo/flutter-cluster-dashboard/files/kvm.conf b/recipes-demo/flutter-cluster-dashboard/files/kvm.conf
new file mode 100644
index 00000000..0a38143e
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/kvm.conf
@@ -0,0 +1,3 @@
+[Unit]
+Wants=network-online.target
+After=network-online.target
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index 925a2860..c45e2808 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-clust
file://cluster-dashboard.yaml \
file://cluster-dashboard.yaml.demo \
file://cluster-dashboard.token \
+ file://kvm.conf \
"
PV = "1.0+git${SRCPV}"
@@ -36,6 +37,8 @@ SYSTEMD_SERVICE:${PN} = "flutter-cluster-dashboard.service"
do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
+
install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
@@ -60,7 +63,10 @@ RCONFLICTS:${PN}-conf = "${PN}-conf-demo"
ALTERNATIVE:${PN}-conf = "cluster-dashboard.yaml"
ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default"
-FILES:${PN}-conf-demo += "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.demo"
+FILES:${PN}-conf-demo += " \
+ ${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.demo \
+ ${systemd_system_unitdir}/flutter-cluster-dashboard.service.d/kvm.conf \
+"
RDEPENDS:${PN}-conf-demo = "${PN}"
RPROVIDES:${PN}-conf-demo = "cluster-dashboard.yaml"
RCONFLICTS:${PN}-conf-demo = "${PN}-conf"