summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
diff options
context:
space:
mode:
authorHritik Chouhan <hritikc3961@gmail.com>2022-09-10 20:35:16 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-22 10:35:44 +0000
commite252feedd4b3025ecdb71e2d3846e6e632b3e844 (patch)
tree8ce9d5e976bab2e0d53b522534468b64796f019c /recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
parent8bab3bb3dd1d436bff0886b04b1df1261a0ae57c (diff)
Add recipes for flutter apps
- This add the flutter dashboard,hvac,navigation, mediaplayer apps in the AGL. - Pin all the flutter apps in IVI flutter demo homescreen. - Add config file for each app for kuksaAuthToken and mapboxAccessToken. Bug-AGL: SPEC-4560 Change-Id: If5f58e6ccc402f56fef66cc29d3959b834c4e27c Signed-off-by: Hritik Chouhan <hritikc3961@gmail.com>
Diffstat (limited to 'recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb')
-rw-r--r--recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb21
1 files changed, 19 insertions, 2 deletions
diff --git a/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb b/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
index 822bb804..71d988db 100644
--- a/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
+++ b/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
@@ -11,10 +11,14 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
-SRC_URI = "git://github.com/hritik-chouhan/dashboard_for_recipe.git;protocol=https;branch=main"
-SRCREV = "c3234da907ff46fb113f308b5ab257089fdcab4f"
+SRC_URI = "git://github.com/hritik-chouhan/dashboard_for_recipe.git;protocol=https;branch=main \
+ file://dashboard_config.yaml \
+ "
+
+SRCREV = "5b0e5cdc3ba8b00a7e53b46e8b3e656cd09822bb"
S = "${WORKDIR}/git"
+
inherit agl-app flutter-app
# flutter-app
@@ -28,3 +32,16 @@ FLUTTER_BUILD_ARGS = "bundle -v"
AGL_APP_TEMPLATE = "agl-app-flutter"
AGL_APP_ID = "dashboard_app"
AGL_APP_NAME = "Flutter Dashboard"
+
+
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/dashboard_config.yaml ${D}${sysconfdir}/xdg/AGL/
+
+
+
+}
+
+FILES:${PN} += "${sysconfdir}/xdg/AGL"
+