summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-09-19 08:02:08 -0400
committerScott Murray <scott.murray@konsulko.com>2023-09-20 17:06:46 +0000
commitd4d6744afb63b822a31c683b6510c54f7bcd74bf (patch)
tree0cb14642353b71cd6adcbbe780b21e9c5708d352 /recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
parent55ecd266150ce3613c50304dc2476e81ae0a0f1c (diff)
flutter-dashboard: update SRCREV
Update flutter-dashboard SRCREV to pick up KUKSA.val databroker gRPC API changes, update its YAML configuration file to match, and add the JWT authorization token the configuration requires. Bug-AGL: SPEC-4762 Change-Id: I8a2e2da5bf5a03c9e935b91b9b25c1aa0610c399 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29231 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'recipes-demo/flutter-dashboard/flutter-dashboard_git.bb')
-rw-r--r--recipes-demo/flutter-dashboard/flutter-dashboard_git.bb23
1 files changed, 12 insertions, 11 deletions
diff --git a/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb b/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
index a207d9e8..64850e19 100644
--- a/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
+++ b/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
@@ -1,24 +1,19 @@
SUMMARY = "Flutter Dashboard"
DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
-
HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard"
-
-BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
-
SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
-
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard;protocol=https;branch=${AGL_BRANCH} \
- file://dashboard_config.yaml \
- "
+ file://dashboard.yaml \
+ file://dashboard.token \
+"
+SRCREV = "e389b9fa646f90d50e853c2dbf870cdf9f9b80b7"
-SRCREV = "adc3fca51b9ebfc23b503126065d97d692d0ec64"
S = "${WORKDIR}/git"
-
inherit agl-app flutter-app
# flutter-app
@@ -34,9 +29,15 @@ AGL_APP_ID = "dashboard_app"
AGL_APP_NAME = "Dashboard"
do_install:append() {
- install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/dashboard_config.yaml ${D}${sysconfdir}/xdg/AGL/
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/dashboard
+ install -m 0644 ${WORKDIR}/dashboard.yaml ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/dashboard.token ${D}${sysconfdir}/xdg/AGL/dashboard/
}
FILES:${PN} += "${sysconfdir}/xdg/AGL"
+RDEPENDS:${PN} += "flutter-auto"