summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-09-19 07:44:23 -0400
committerScott Murray <scott.murray@konsulko.com>2023-09-20 17:06:36 +0000
commit55ecd266150ce3613c50304dc2476e81ae0a0f1c (patch)
treee8624898ace1f25abe9c93bc7175cd278d9b535c /recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
parentcb73462f31f08f8545ccd9a2316ebd5a3af2bbd1 (diff)
flutter-homescreen: update SRCREV
Update flutter-homescreen SRCREV to pick up KUKSA.val databroker gRPC API changes, update its YAML configuration file to match, and add the JWT authorization token the configuration requires. Bug-AGL: SPEC-4762, SPEC-4903 Change-Id: I230f77aa120d76af928990bd2b7b1d8eacdcaaaa Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29230 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'recipes-demo/flutter-homescreen/flutter-homescreen_git.bb')
-rw-r--r--recipes-demo/flutter-homescreen/flutter-homescreen_git.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
index 62ea1e17..8f2062f1 100644
--- a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
+++ b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
@@ -9,9 +9,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-homescreen;protocol=https;branch=${AGL_BRANCH} \
file://flutter-homescreen.json \
file://flutter-homescreen.service \
- file://homescreen_config.yaml \
+ file://homescreen.yaml \
+ file://homescreen.token \
"
-SRCREV = "5ce59ba69f1451ec18c565b7b18301856553f574"
+SRCREV = "cbbb9f40e283d12f6c52ad28609516f390316f7a"
S = "${WORKDIR}/git"
@@ -31,8 +32,13 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
- install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/homescreen_config.yaml ${D}${sysconfdir}/xdg/AGL/
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/homescreen
+ install -m 0644 ${WORKDIR}/homescreen.yaml ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
}
FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL"