summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2023-05-31 18:37:12 -0700
committerScott Murray <scott.murray@konsulko.com>2023-06-01 19:00:13 -0400
commitde1dccae31b3c7c62f0e19102b7223d747f413ed (patch)
tree475006ad03e45aca7c5d456e8af3ee2795341596 /recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
parent72b82ba156081172f6d3638a1139980a094e87a0 (diff)
Flutter bbclass refactor
-Removes use of flutter bbclass runtime modes Installed modes are determined by flutter-engine package config flags. Default modes are debug, profile, and release. -Single json file based on runtime=release. If additional parameters are needed this happens as part of workspace automation. Scott Murray: - update packagegroup-agl-demo-platform-flutter Bug-AGL: SPEC-4819 Change-Id: I58fc1b30ea3367ec5f47f52b60951cf0be31dcbc Signed-off-by: Joel Winarske <joel.winarske@gmail.com> Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo/flutter-homescreen/flutter-homescreen_git.bb')
-rw-r--r--recipes-demo/flutter-homescreen/flutter-homescreen_git.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
index e97bded1..c4142774 100644
--- a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
+++ b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
@@ -7,9 +7,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-homescreen;protocol=https;branch=${AGL_BRANCH} \
- file://flutter-homescreen-debug.json \
- file://flutter-homescreen-profile.json \
- file://flutter-homescreen-release.json \
+ file://flutter-homescreen.json \
file://flutter-homescreen.service \
file://homescreen_config.yaml \
"
@@ -24,9 +22,7 @@ FLUTTER_BUILD_ARGS = "bundle -v"
inherit flutter-app
-APP_CONFIG = "flutter-homescreen-release.json"
-APP_CONFIG:class-runtimedebug = "flutter-homescreen-debug.json"
-APP_CONFIG:class-runtimeprofile = "flutter-homescreen-profile.json"
+APP_CONFIG = "flutter-homescreen.json"
do_install:append() {
install -D -m 0644 ${WORKDIR}/flutter-homescreen.service ${D}${systemd_user_unitdir}/flutter-homescreen.service
#0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
# We have a conf and classes directory, add to BBPATH
BBPATH .= ":${LAYERDIR}"

# We have recipes-* directories, add to BBFILES
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
	${LAYERDIR}/recipes-*/*/*.bbappend"

BBFILE_COLLECTIONS += "app-framework"
BBFILE_PATTERN_app-framework = "^${LAYERDIR}/"
BBFILE_PRIORITY_app-framework = "70"

LAYERSERIES_COMPAT_app-framework = "thud"