summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-06-02 10:52:32 -0400
committerScott Murray <scott.murray@konsulko.com>2023-06-02 11:00:52 -0400
commitcce52591f8e00ae41ae380a597d620b0856d004d (patch)
tree5df72538fd9b18f550ef7cedf42cc9990cc3ac7a /recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
parentde1dccae31b3c7c62f0e19102b7223d747f413ed (diff)
Do not hard-code Flutter version and runtime type
Rework the flutter-homescreen and flutter-cluster-dashboard systemd units to get the Flutter version and runtime type from the environment file installed by the new agl-flutter-env recipe, and update their JSON configuration files to remove the hardcoding of their bundle paths. Bug-AGL: SPEC-4819 Change-Id: I841db2cbb3acfe4aad173e9b8aa25ff2e201c2e2 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo/flutter-homescreen/flutter-homescreen_git.bb')
-rw-r--r--recipes-demo/flutter-homescreen/flutter-homescreen_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
index c4142774..0bd1ae19 100644
--- a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
+++ b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
@@ -22,17 +22,18 @@ FLUTTER_BUILD_ARGS = "bundle -v"
inherit flutter-app
-APP_CONFIG = "flutter-homescreen.json"
+APP_CONFIG = "${BPN}.json"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/flutter-homescreen.service ${D}${systemd_user_unitdir}/flutter-homescreen.service
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- ln -s ../flutter-homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/flutter-homescreen.service
+ ln -s ../${BPN}.service ${D}${systemd_user_unitdir}/agl-session.target.wants/${BPN}.service
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/flutter-homescreen.json
+ install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
install -d ${D}${sysconfdir}/xdg/AGL
install -m 0644 ${WORKDIR}/homescreen_config.yaml ${D}${sysconfdir}/xdg/AGL/
}
FILES:${PN} += "${datadir} ${systemd_user_unitdir} ${sysconfdir}/xdg/AGL"
+RDEPENDS:${PN} += "flutter-auto agl-flutter-env"