aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2024-09-06 08:02:09 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-09-09 18:37:14 +0000
commit65e6910f05a65aff631187ff8576e471b5798bf1 (patch)
tree07ce2e397b7ef49f77dfb0ea1cb641c90211d256 /recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
parent76ce5a83f797e4f49454ffab1fc41542e6baf960 (diff)
flutter SDK 3.24.2
-update flutter-ics-homescreen and flutter-instrument-cluster Change-Id: I28ceb1999f79c1b2889a9f2b9e900fe825b12d77 Signed-off-by: Joel Winarske <joel.winarske@gmail.com> (Updated flutter-cluster-dashboard systemd unit file) Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30267 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb')
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index 0d4862e6b..508df276a 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -7,7 +7,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;protocol=https;branch=${AGL_BRANCH} \
- file://flutter-ics-homescreen.json \
+ file://ics-homescreen.toml \
file://flutter-ics-homescreen.service \
file://ics-homescreen.yaml \
file://ics-homescreen.yaml.gateway-demo \
@@ -17,16 +17,15 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;p
file://radio-presets.yaml \
file://kvm.conf \
"
-SRCREV = "1e99e3a52f3d4d81d7cc890630ac591d38f731df"
+SRCREV = "0c24d7f6ebdb688d3aee492b5f84aa21e141f7e7"
S = "${WORKDIR}/git"
PUBSPEC_APPNAME = "flutter_ics_homescreen"
-FLUTTER_BUILD_ARGS = "bundle -v"
inherit flutter-app systemd update-alternatives
-APP_CONFIG = "${BPN}.json"
+APP_CONFIG = "ics-homescreen.toml"
SYSTEMD_SERVICE:${PN} = "flutter-ics-homescreen.service"
@@ -42,7 +41,13 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
+ # determine build type based on what flutter-engine installed.
+ for runtime_mode in ${FLUTTER_RUNTIME_MODES}
+ do
+ install -D -m 0644 ${WORKDIR}/${APP_CONFIG} \
+ ${D}${datadir}/flutter/${PUBSPEC_APPNAME}/${FLUTTER_SDK_VERSION}/${runtime_mode}/config.toml
+ done
+
# VIS authorization token file for KUKSA.val should ideally not
# be readable by other users, but currently that's not doable