summaryrefslogtreecommitdiffstats
path: root/recipes-demo/flutter-mediaplayer
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-10-26 17:09:06 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-10-31 11:21:22 +0000
commit9aa37897cdf3bcd7f4d5650c11bc2b679a6b9099 (patch)
tree4540267434e319ca4a53156a4c88015fa948df52 /recipes-demo/flutter-mediaplayer
parent7832492d87871cfb382b58c1eeb9f182537c0c60 (diff)
Import flutter apps from master branch
For CES we will evolve the flutter applications. Import the state from master. Bug-AGL: SPEC-4592 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I6f561d76a8fee3903eb1431d0e5e141588dc365d
Diffstat (limited to 'recipes-demo/flutter-mediaplayer')
-rw-r--r--recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb b/recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb
new file mode 100644
index 00000000..cfcfa265
--- /dev/null
+++ b/recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Flutter MediaPlayer app for IVI"
+DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux"
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-mediaplayer"
+
+BUGTRACKER = "https://github.com/hritik-chouhan/musicplayer/issues"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
+
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "735de5a38ea937ee13157f6ac594053ddb8b027b"
+S = "${WORKDIR}/git"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "musicplayer"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "musicplayer"
+AGL_APP_NAME = "Flutter MediaPlayer"