summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-homescreen/html5-homescreen_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-07-27 17:02:54 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-27 19:39:16 -0400
commit731adc93b2fed74bc4410dff510fb019d10f253f (patch)
tree77f17ab8b7b906a288d84f99f2cb4cde6fa537ff /recipes-demo/html5-homescreen/html5-homescreen_git.bb
parentf22d415e4b1290cbba736df7d4cafa043dc8f8f2 (diff)
Updates for application enumeration via systemd units
Update application recipes to use the new agl-app.bbclass to install the now required by applaunchd systemd template unit instances. The previously used .desktop files have been removed, and it is believed that the required configuration with respect to application display names has been captured in the new agl-app configuration variables. Bug-AGL: SPEC-4466 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2925a68f911646c287bc7128bb0e5f43d55ce7bf
Diffstat (limited to 'recipes-demo/html5-homescreen/html5-homescreen_git.bb')
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index db659760..65de7298 100644
--- a/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -26,13 +26,13 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
+ install -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
}