summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-homescreen
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-03-01 17:34:33 +0100
committerJose Dapena Paz <jdapena@igalia.com>2022-03-07 19:29:47 +0100
commit54346ef22702aa41531aaa0e6f662cc91fce4905 (patch)
tree9b46ec5822001c0dc2b6c9aade22cf737806e0a7 /recipes-demo/html5-homescreen
parentd787e10f87845a06cf15d11e592af4ae69d60ee8 (diff)
meta-agl-demo: use HTML5 homescreen+background+launcher in HTML5 demo
Adapt to use again html5-homescreen and html5-background: * Added html5-background and html5-homescreen. * Now only html5-homescreen is launched from systemd, while html5-launcher and html5-background are launched from html5-homescreen logic. * Use landscape weston configuration as expected in HTML5 demo. * Pass --agl-shell-appid=homescreen to WebAppMgr script so it knows which application implements the UI of agl_shell wayland protocol. chromium: bc1410d..fa99cf3344 fa99cf3344 [op][agl][wayland] Activate applications when requested from applaunchd ab1a4cf05d [op][agl][injection] AGL D-Bus implementation of PAL appservice e5f6143e55 [op][agl][injection] Add application service injection wam: b0c1e46..8dd3f17 8dd3f17 [op][agl][wayland] Remove unused role code. defc5af [op][agl][wayland] Fix: do not ignore Panel shell surface type. 6683b08 [op][agl][wayland] Set AGL application ID in all cases 0bb9814 [op][agl][wayland] Properly adapt dimensions for web apps using panel 9af0d23 [op][agl][wayland] Properly pass surface size, type and edge to chromium e6df86b [op][agl][injection] Declare in web app XML the required injections Bug-AGL: SPEC-4250 Change-Id: Ie1b1181f3a67ea2ada1912db53e360178a4cf443 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Diffstat (limited to 'recipes-demo/html5-homescreen')
-rw-r--r--recipes-demo/html5-homescreen/files/homescreen.service15
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb41
2 files changed, 56 insertions, 0 deletions
diff --git a/recipes-demo/html5-homescreen/files/homescreen.service b/recipes-demo/html5-homescreen/files/homescreen.service
new file mode 100644
index 00000000..20ed2ee1
--- /dev/null
+++ b/recipes-demo/html5-homescreen/files/homescreen.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=AGL Homescreen
+Requires=WebAppMgr.service dbus.service
+After=WebAppMgr.service dbus.service
+
+[Service]
+Type=simple
+Environment=AFM_ID=homescreen
+Environment=AFM_APP_INSTALL_DIR=/usr/lib/wam_apps/html5-homescreen/
+ExecStartPre=sleep 1
+ExecStart=/usr/bin/WebAppMgr
+Restart=on-failure
+
+[Install]
+WantedBy=agl-session.target
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
new file mode 100644
index 00000000..1d5f14a4
--- /dev/null
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -0,0 +1,41 @@
+SUMMARY = "AGL HTML5 Homescreen"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-homescreen/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH} \
+ file://homescreen.service \
+"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS = "nodejs-native"
+
+do_compile() {
+ bldcmd=${S}/autobuild/agl/autobuild
+ cd ${S}
+ $bldcmd build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+ install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
+ ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+}
+
+FILES_${PN} = " \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+ ${systemd_user_unitdir} \
+"
+
+RCONFLICTS_${PN} = "homescreen"
+RDEPENDS_${PN} = "applaunchd html5-background" \ No newline at end of file