summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-launcher/html5-launcher_git.bb
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-04-18 16:40:45 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-13 12:08:08 +0000
commitf3e2bfbfb64222d1d80ac12f3e615ef5e392a842 (patch)
tree17ab1c0aa1395fec6012da58469f78f231ab8b80 /recipes-demo/html5-launcher/html5-launcher_git.bb
parenta8a530182a580540dc3c6c1f54933e0b53a13e03 (diff)
wam, chromium, html5-*: improve initial frame, and drop usage of config.xml
Move to use appinfo.json, new CLI interface, and fix flickering partially. chromium87: be0370b198..c9a66f75a7 c9a66f75a7 fixup! [op][n_upsable][splash][fmp] New splash and FMP implementation d7953f5e17 Revert "[op][agl][splash] Show immediately apps" wam: 8dd3f17..f4c2e95 f4c2e95 fixup! agl/web_app_manager_service_agl: Fix minor typo c072a91 agl/web_app_manager_service_agl: Fix minor typo 761961c web_runtime_agl, web_app_manager_service_agl: Add WebOS appinfo.json support 1ac280e web_runtime_agl: Pass arguments rather than env variables 6e0477f web_runtime_agl: remove setupsurface, nobody is using it 0d83a34 web_runtime_agl: Remove CYNOGARA auth token 4159489 fixup! [op][agl][wayland] Properly adapt dimensions for web apps using panel html5-homescreen: 21bd1dc..7d89048 7d89048 Launch background after launcher. 5c9e060 Use appinfo.json instead of config.xml * Change branch to master html5-launcher: b371797..cb6b66c cb6b66c Use appinfo.json instead of config.xml * Change branch to master html5-background: 16db46b..7b79640 7b79640 Use appinfo.json instead of config.xml 160a4f9 Add .gitreview file * Use AGL gerrit and change branch to master html5-hvac: 45641bf..e64d69b e64d69b Use appinfo.json instead of config.xml * Change branch to master Bug-AGL: SPEC-3982, SPEC-4251, SPEC-4301, SPEC-4312, SPEC-4315 Change-Id: Ibd2bc428910e6e39c52e14b8e969fdea77000a84 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Diffstat (limited to 'recipes-demo/html5-launcher/html5-launcher_git.bb')
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index ecafd19e9..52d7077d6 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -9,10 +9,10 @@ S = "${WORKDIR}/git"
B = "${WORKDIR}/build"
SRC_URI = " \
- git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
file://launcher.desktop \
"
-SRCREV = "b37179742fac1053ba621cfa12938ec6536cf1f7"
+SRCREV = "cb6b66c3bd94a6ab18cad3ad87c827d4f7e623e9"
DEPENDS = "nodejs-native"
kground-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
/*
 * Copyright (C) 2015-2020 "IoT.bzh"
 * Author: José Bollo <jose.bollo@iot.bzh>
 *
 * Licensed under the Apache License, Version 2.0 (the "License");
 * you may not use this file except in compliance with the License.
 * You may obtain a copy of the License at
 *
 *   http://www.apache.org/licenses/LICENSE-2.0
 *
 * Unless required by applicable law or agreed to in writing, software
 * distributed under the License is distributed on an "AS IS" BASIS,
 * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 * See the License for the specific language governing permissions and
 * limitations under the License.
 */


#pragma once

#if WITH_LEGACY_BINDING_V2 && WITH_DYNAMIC_BINDING

struct afb_apiset;
struct afb_binding_v2;
struct afb_binding_data_v2;
struct afb_xreq;
struct json_object;

extern int afb_api_so_v2_add(const char *path, void *handle, struct afb_apiset *declare_set, struct afb_apiset * call_set);
extern int afb_api_so_v2_add_binding(const struct afb_binding_v2 *binding, void *handle, struct afb_apiset *declare_set, struct afb_apiset * call_set, struct afb_binding_data_v2 *data, const char *path);

extern void afb_api_so_v2_process_call(const struct afb_binding_v2 *binding, struct afb_xreq *xreq);
extern struct json_object *afb_api_so_v2_make_description_openAPIv3(const struct afb_binding_v2 *binding, const char *apiname);

#endif