summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-launcher
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-05-02 20:22:08 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-13 12:08:08 +0000
commitafed300f173dea8fe45bfde20f9c20d7c23658a4 (patch)
tree369fb753d0360e4ac2ea360131f1c1304f2c8763 /recipes-demo/html5-launcher
parentd38602afcce435a102ecb0aa0c40231c266d8ddf (diff)
chromium, html5-*: adapt to kirkstone
Adapt the recipes to the changes required by Yocto kirkstone: * Explicit python2 dependency. * Replace _ with : as separator in variables. * Explicit pkgconfig dependency. * Assume always upstream ozone wayland. chromium91: 2c7cb69495..d052051b3b d052051b3b [op][ups][build] Fix with more recent libstdc++ in kirkstone deb1439137 [op][ups][build] Fix breakpad build with kirkstone glibc. e6ee1dd0d0 [op][ups][build] Fix abseil-cpp build with glibc in kirkstone wam: 692f706..31840bc 31840bc [op][w_upsable] IWYU: std::string used in LogManagerConsole 15ce17e [op][n_upsable][build] IWYU: std::numeric_limit used in WebPageBlink missing include. 848565d fixup! [op][agl] New QtLess AGL port html5-homescreen: 5c9e060..fc0ffa4 fc0ffa4 Update to recent dependencies a42b304 Launch background after launcher. html5-launcher: cb6b66c..1283e3b 1283e3b Update dependencies. html5-background: 7b79640..e91be22 e91be22 Update to recent dependencies. html5-hvac: e64d69b..6abbe87 6abbe87 Update to recent dependencies. Bug-AGL: SPEC-4261 Change-Id: I48581a57df3ff22d8aaab2334e4f9b4127a6d427 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Diffstat (limited to 'recipes-demo/html5-launcher')
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index 52d7077d..59087006 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -12,7 +12,9 @@ SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
file://launcher.desktop \
"
-SRCREV = "cb6b66c3bd94a6ab18cad3ad87c827d4f7e623e9"
+SRCREV = "1283e3bddd4655be0d5208fbbcd9535f8f1ff0f6"
+
+inherit pythonnative
DEPENDS = "nodejs-native"
@@ -33,10 +35,10 @@ do_install() {
install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
}
-FILES_${PN} = " \
+FILES:${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
${APPLICATIONS_DIR} \
"
-RCONFLICTS_${PN} = "launcher"
-RDEPENDS_${PN} = "applaunchd"
+RCONFLICTS:${PN} = "launcher"
+RDEPENDS:${PN} = "applaunchd"