summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-launcher
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-03-01 17:34:33 +0100
committerJose Dapena Paz <jdapena@igalia.com>2022-03-07 19:29:47 +0100
commit54346ef22702aa41531aaa0e6f662cc91fce4905 (patch)
tree9b46ec5822001c0dc2b6c9aade22cf737806e0a7 /recipes-demo/html5-launcher
parentd787e10f87845a06cf15d11e592af4ae69d60ee8 (diff)
meta-agl-demo: use HTML5 homescreen+background+launcher in HTML5 demo
Adapt to use again html5-homescreen and html5-background: * Added html5-background and html5-homescreen. * Now only html5-homescreen is launched from systemd, while html5-launcher and html5-background are launched from html5-homescreen logic. * Use landscape weston configuration as expected in HTML5 demo. * Pass --agl-shell-appid=homescreen to WebAppMgr script so it knows which application implements the UI of agl_shell wayland protocol. chromium: bc1410d..fa99cf3344 fa99cf3344 [op][agl][wayland] Activate applications when requested from applaunchd ab1a4cf05d [op][agl][injection] AGL D-Bus implementation of PAL appservice e5f6143e55 [op][agl][injection] Add application service injection wam: b0c1e46..8dd3f17 8dd3f17 [op][agl][wayland] Remove unused role code. defc5af [op][agl][wayland] Fix: do not ignore Panel shell surface type. 6683b08 [op][agl][wayland] Set AGL application ID in all cases 0bb9814 [op][agl][wayland] Properly adapt dimensions for web apps using panel 9af0d23 [op][agl][wayland] Properly pass surface size, type and edge to chromium e6df86b [op][agl][injection] Declare in web app XML the required injections Bug-AGL: SPEC-4250 Change-Id: Ie1b1181f3a67ea2ada1912db53e360178a4cf443 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Diffstat (limited to 'recipes-demo/html5-launcher')
-rw-r--r--recipes-demo/html5-launcher/files/launcher.service15
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb11
2 files changed, 6 insertions, 20 deletions
diff --git a/recipes-demo/html5-launcher/files/launcher.service b/recipes-demo/html5-launcher/files/launcher.service
deleted file mode 100644
index 67dcf5e1..00000000
--- a/recipes-demo/html5-launcher/files/launcher.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=AGL Launcher
-Requires=WebAppMgr.service dbus.service
-After=WebAppMgr.service dbus.service
-
-[Service]
-Type=simple
-Environment=AFM_ID=launcher
-Environment=AFM_APP_INSTALL_DIR=/usr/lib/wam_apps/html5-launcher/
-ExecStartPre=sleep 1
-ExecStart=/usr/bin/WebAppMgr
-Restart=on-failure
-
-[Install]
-WantedBy=agl-session.target
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index 2a4f7ed1..61899e4c 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -10,7 +10,7 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
- file://launcher.service \
+ file://launcher.desktop \
"
SRCREV = "${AGL_APP_REVISION}"
@@ -23,18 +23,19 @@ do_compile() {
}
WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
- ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+ install -d ${D}${APPLICATIONS_DIR}
+ install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
}
FILES_${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
- ${systemd_user_unitdir} \
+ ${APPLICATIONS_DIR} \
"
RCONFLICTS_${PN} = "launcher"
+RDEPENDS_${PN} = "applaunchd" \ No newline at end of file