summaryrefslogtreecommitdiffstats
path: root/recipes-demo/html5-mediaplayer
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-07-27 17:02:54 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-27 19:39:16 -0400
commit731adc93b2fed74bc4410dff510fb019d10f253f (patch)
tree77f17ab8b7b906a288d84f99f2cb4cde6fa537ff /recipes-demo/html5-mediaplayer
parentf22d415e4b1290cbba736df7d4cafa043dc8f8f2 (diff)
Updates for application enumeration via systemd units
Update application recipes to use the new agl-app.bbclass to install the now required by applaunchd systemd template unit instances. The previously used .desktop files have been removed, and it is believed that the required configuration with respect to application display names has been captured in the new agl-app configuration variables. Bug-AGL: SPEC-4466 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2925a68f911646c287bc7128bb0e5f43d55ce7bf
Diffstat (limited to 'recipes-demo/html5-mediaplayer')
-rw-r--r--recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop11
-rw-r--r--recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb17
2 files changed, 7 insertions, 21 deletions
diff --git a/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop b/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop
deleted file mode 100644
index 4322d6c3..00000000
--- a/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=HTML5 Media Player
-Comment=Media player
-GenericName=Media player
-Exec=/usr/bin/WebAppMgr --appid=webapps-mediaplayer --app-install-dir=/usr/lib/wam_apps/html5-mediaplayer/
-Icon=settings
-Terminal=false
-Type=Application
-Categories=System;
-StartupNotify=true
diff --git a/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb b/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
index 4fd1df2d..53efa8fd 100644
--- a/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
+++ b/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=master \
- file://webapps-mediaplayer.desktop \
"
SRCREV = "07adebd03e37a790462f80b6f3bb001bad7e6748"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-mediaplayer"
+AGL_APP_NAME = "HTML5 Media Player"
DEPENDS = "nodejs-native"
@@ -26,17 +29,11 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/webapps-mediaplayer.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"