summaryrefslogtreecommitdiffstats
path: root/recipes-demo/hvac/hvac_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-16 00:53:55 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-16 00:53:55 -0400
commitde875a8bcbad58763d17c1b462970dca10280b95 (patch)
tree153a44ede3d0384e37c257c2cf5e05aaee743ad4 /recipes-demo/hvac/hvac_git.bb
parent1bc8975efe0a725124c0780ae4aabd3259511fb2 (diff)
hvac: update recipe
Update hvac app recipe to work with the new VehicleSignals API in libqtappfw. Like the updates previously done for other apps, this means installing the new configuration file and associated JSON web token file for KUKSA.val authorization. Bug-AGL: SPEC-4409 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3a21e381a315d3226d026a8d82aa1b82fc42ad7e
Diffstat (limited to 'recipes-demo/hvac/hvac_git.bb')
-rw-r--r--recipes-demo/hvac/hvac_git.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-demo/hvac/hvac_git.bb b/recipes-demo/hvac/hvac_git.bb
index ffa1234fe..2f3307c91 100644
--- a/recipes-demo/hvac/hvac_git.bb
+++ b/recipes-demo/hvac/hvac_git.bb
@@ -16,13 +16,29 @@ DEPENDS = " \
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH} \
+ file://hvac.conf \
+ file://hvac.token \
+"
SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/hvac
+ install -m 0644 ${WORKDIR}/hvac.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/hvac.token ${D}${sysconfdir}/xdg/AGL/hvac/
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += " \