summaryrefslogtreecommitdiffstats
path: root/recipes-demo/hvac
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-11-22 17:58:54 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-25 11:25:41 +0000
commit24e55fccab51e217d4452968b082f0531a05fcb5 (patch)
treee3e0dd1e9dfed15c9f94ec0af20f2b6590b86845 /recipes-demo/hvac
parent275de1d5dceae84c872e354f2f8b15ad275f97ae (diff)
Update Qt demo app SRCREVs
Update Qt demo app SRCREVs to pick up their Qt6 updates, and drop the now unnecssary Qt6 patches. Also, the MapBox configuration support has been removed from the ondemandnavi-config recipe, as that backend is no longer supported by QtLocation in Qt6. Bug-AGL: SPEC-5294 Change-Id: Ib44c6be83c3d4654c9ed5adffa3e9d34057eb2ae Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30543 ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-demo/hvac')
-rw-r--r--recipes-demo/hvac/hvac/0001-Migrate-to-Qt-6.patch119
-rw-r--r--recipes-demo/hvac/hvac_git.bb3
2 files changed, 1 insertions, 121 deletions
diff --git a/recipes-demo/hvac/hvac/0001-Migrate-to-Qt-6.patch b/recipes-demo/hvac/hvac/0001-Migrate-to-Qt-6.patch
deleted file mode 100644
index f19cabc4b..000000000
--- a/recipes-demo/hvac/hvac/0001-Migrate-to-Qt-6.patch
+++ /dev/null
@@ -1,119 +0,0 @@
-From 2a425094986a7ad5c584803e03ff723689fa1b47 Mon Sep 17 00:00:00 2001
-From: Indivara Weerasuriya <1806262-indivara@users.noreply.git.qt.io>
-Date: Wed, 24 Jul 2024 09:18:03 +0900
-Subject: [PATCH] Migrate to Qt 6
-
----
- app/HVAC.qml | 19 +++++++++----------
- app/SeatHeatButton.qml | 10 +++++-----
- 2 files changed, 14 insertions(+), 15 deletions(-)
-
-diff --git a/app/HVAC.qml b/app/HVAC.qml
-index 4e27e2d..592dd1b 100644
---- a/app/HVAC.qml
-+++ b/app/HVAC.qml
-@@ -43,7 +43,6 @@ ApplicationWindow {
- anchors.centerIn: parent
- width: Window.width
- height: Window.height
-- scale: Window.scale
-
- ColumnLayout {
- anchors.fill: parent
-@@ -53,7 +52,7 @@ ApplicationWindow {
- Layout.fillHeight: true
- Layout.alignment: Qt.AlignHCenter
- Image {
-- source: './images/HMI_HVAC_Fan_Icon.svg'
-+ source: 'qrc:/images/HMI_HVAC_Fan_Icon.svg'
- }
- Item {
- width: 1080 * 0.8
-@@ -100,8 +99,8 @@ ApplicationWindow {
- Layout.fillWidth: true
- spacing: 20
- ToggleButton {
-- onImage: './images/HMI_HVAC_Active.svg'
-- offImage: './images/HMI_HVAC_Inactive.svg'
-+ onImage: 'qrc:/images/HMI_HVAC_Active.svg'
-+ offImage: 'qrc:/images/HMI_HVAC_Inactive.svg'
- Label {
- anchors.centerIn: parent
- color: parent.checked ? '#00ADDC' : '#848286'
-@@ -113,8 +112,8 @@ ApplicationWindow {
- }
- }
- ToggleButton {
-- onImage: './images/HMI_HVAC_Active.svg'
-- offImage: './images/HMI_HVAC_Inactive.svg'
-+ onImage: 'qrc:/images/HMI_HVAC_Active.svg'
-+ offImage: 'qrc:/images/HMI_HVAC_Inactive.svg'
- Label {
- anchors.centerIn: parent
- color: parent.checked ? '#00ADDC' : '#848286'
-@@ -126,8 +125,8 @@ ApplicationWindow {
- }
- }
- ToggleButton {
-- onImage: './images/HMI_HVAC_Circulation_Active.svg'
-- offImage: './images/HMI_HVAC_Circulation_Inactive.svg'
-+ onImage: 'qrc:/images/HMI_HVAC_Circulation_Active.svg'
-+ offImage: 'qrc:/images/HMI_HVAC_Circulation_Inactive.svg'
- onCheckedChanged: {
- console.debug('Circulation', checked)
- }
-@@ -157,8 +156,8 @@ ApplicationWindow {
- Repeater {
- model: ['AirDown', 'AirUp', 'AirRight', 'Rear', 'Front']
- ToggleButton {
-- onImage: './images/HMI_HVAC_%1_Active.svg'.arg(model.modelData)
-- offImage: './images/HMI_HVAC_%1_Inactive.svg'.arg(model.modelData)
-+ onImage: 'qrc:/images/HMI_HVAC_%1_Active.svg'.arg(model.modelData)
-+ offImage: 'qrc:/images/HMI_HVAC_%1_Inactive.svg'.arg(model.modelData)
- onCheckedChanged: {
- console.debug(model.modelData, checked)
- }
-diff --git a/app/SeatHeatButton.qml b/app/SeatHeatButton.qml
-index 3495cf6..7e2e1d4 100644
---- a/app/SeatHeatButton.qml
-+++ b/app/SeatHeatButton.qml
-@@ -33,13 +33,13 @@ Item {
- anchors.centerIn: parent
- Image {
- id: chair
-- source: './images/HMI_HVAC_%1_Chair_OFF.svg'.arg(root.side)
-+ source: 'qrc:/images/HMI_HVAC_%1_Chair_OFF.svg'.arg(root.side)
- states: [
- State {
- when: root.headLevel > 0
- PropertyChanges {
- target: chair
-- source: './images/HMI_HVAC_%1_Chair_ON.svg'.arg(root.side)
-+ source: 'qrc:/images/HMI_HVAC_%1_Chair_ON.svg'.arg(root.side)
- }
- }
- ]
-@@ -48,20 +48,20 @@ Item {
- id: indicator
- width: 178
- height: 18
-- source: './images/HMI_HVAC_ChairIndicator_OFF.svg'
-+ source: 'qrc:/images/HMI_HVAC_ChairIndicator_OFF.svg'
- states: [
- State {
- when: root.headLevel === 1
- PropertyChanges {
- target: indicator
-- source: './images/HMI_HVAC_ChairIndicator_One.svg'
-+ source: 'qrc:/images/HMI_HVAC_ChairIndicator_One.svg'
- }
- },
- State {
- when: root.headLevel === 2
- PropertyChanges {
- target: indicator
-- source: './images/HMI_HVAC_ChairIndicator_Two.svg'
-+ source: 'qrc:/images/HMI_HVAC_ChairIndicator_Two.svg'
- }
- }
- ]
diff --git a/recipes-demo/hvac/hvac_git.bb b/recipes-demo/hvac/hvac_git.bb
index e17490444..c8a53cd57 100644
--- a/recipes-demo/hvac/hvac_git.bb
+++ b/recipes-demo/hvac/hvac_git.bb
@@ -18,9 +18,8 @@ PV = "2.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH} \
file://hvac.conf \
file://hvac.token \
- file://0001-Migrate-to-Qt-6.patch \
"
-SRCREV = "d37674bb6dbb5ceb15c650a0344b0caf624963bc"
+SRCREV = "3ff350bd5376c5a255909b43a7336801e797ca76"
S = "${WORKDIR}/git"