summaryrefslogtreecommitdiffstats
path: root/recipes-demo/hvac
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-12-21 10:00:54 -0500
committerScott Murray <scott.murray@konsulko.com>2021-12-21 10:17:36 -0500
commite3e399730736deb17b4fa36f2fedda39cf510243 (patch)
treed023142cca0a1d2aa34ade9c2e072d65e94ee205 /recipes-demo/hvac
parent1c8e6f77e6c55fbc73779e5ce18926aba176d2fc (diff)
Add updated demo applications back
Add updated recipes for the dashboard, hvac, ondemandnavi, and settings Qt demo applications, as well as for the libqtappfw library they use and its new dependency bluez-glib. The applications are added back to the packagegroup-agl-demo-platform as they were before. Also remove a couple of leftover things in the packagegroup recipe to clean up. Bug-AGL: SPEC-4182 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I0ea36c809d9126284c597cd79eded8ab031205da
Diffstat (limited to 'recipes-demo/hvac')
-rw-r--r--recipes-demo/hvac/hvac_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-demo/hvac/hvac_git.bb b/recipes-demo/hvac/hvac_git.bb
new file mode 100644
index 000000000..ffa1234fe
--- /dev/null
+++ b/recipes-demo/hvac/hvac_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "HVAC application"
+DESCRIPTION = "AGL demonstration HVAC application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/hvac"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = " \
+ qttools-native \
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ libqtappfw \
+"
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 pkgconfig
+
+FILES:${PN} += "${datadir}/icons/"
+
+RDEPENDS:${PN} += " \
+ qtwayland \
+ qtbase-qmlplugins \
+ qtgraphicaleffects-qmlplugins \
+ qtquickcontrols2-agl-style \
+ libqtappfw \
+"
236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315