summaryrefslogtreecommitdiffstats
path: root/recipes-demo/launcher
diff options
context:
space:
mode:
authorIndivara Weerasuriya <indivara.weerasuriya@qt.io>2024-07-30 19:47:24 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-20 13:35:26 +0000
commit59ae0b13d2bb14fbf12117f2f55bfcb6f06f104b (patch)
treeba38354db9033675bde1ad07700d796160450f8f /recipes-demo/launcher
parenta37e8ed0c8f997e13d719c7e5d956b5febc9cfa5 (diff)
Migrate demo app recipes and patch apps to Qt 6
Bug-AGL: SPEC-5294 Change-Id: I6b9ff940745f88af9a3b69e29917082e52b25f88 Signed-off-by: Indivara Weerasuriya <indivara.weerasuriya@qt.io> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30141 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-demo/launcher')
-rw-r--r--recipes-demo/launcher/files/0001-Migrate-to-Qt-6.patch31
-rw-r--r--recipes-demo/launcher/files/launcher.service1
-rw-r--r--recipes-demo/launcher/launcher_git.bb6
3 files changed, 35 insertions, 3 deletions
diff --git a/recipes-demo/launcher/files/0001-Migrate-to-Qt-6.patch b/recipes-demo/launcher/files/0001-Migrate-to-Qt-6.patch
new file mode 100644
index 000000000..93f55fd85
--- /dev/null
+++ b/recipes-demo/launcher/files/0001-Migrate-to-Qt-6.patch
@@ -0,0 +1,31 @@
+From 7e6fb6b5b69979db15b630213ec60e1cf5be7dcf Mon Sep 17 00:00:00 2001
+From: Indivara Weerasuriya <1806262-indivara@users.noreply.git.qt.io>
+Date: Wed, 24 Jul 2024 09:21:02 +0900
+Subject: [PATCH] Migrate to Qt 6
+
+---
+ launcher/qml/Launcher.qml | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/launcher/qml/Launcher.qml b/launcher/qml/Launcher.qml
+index 3aef4e6..8d67f60 100644
+--- a/launcher/qml/Launcher.qml
++++ b/launcher/qml/Launcher.qml
+@@ -19,7 +19,7 @@ import QtQuick 2.13
+ import QtQuick.Layouts 1.1
+ import QtQuick.Controls 2.0
+ import QtQuick.Window 2.13
+-import QtGraphicalEffects 1.0
++import Qt5Compat.GraphicalEffects
+ import AppModel 1.0
+
+ ApplicationWindow {
+@@ -38,7 +38,7 @@ ApplicationWindow {
+
+ Image {
+ anchors.centerIn: parent
+- source: './images/AGL_HMI_Blue_Background_Car-01.png'
++ source: 'qrc:/images/AGL_HMI_Blue_Background_Car-01.png'
+ }
+
+ GridView {
diff --git a/recipes-demo/launcher/files/launcher.service b/recipes-demo/launcher/files/launcher.service
index 00dfd9ad7..51c983cbd 100644
--- a/recipes-demo/launcher/files/launcher.service
+++ b/recipes-demo/launcher/files/launcher.service
@@ -6,6 +6,7 @@ After=homescreen.service applaunchd.service
Type=simple
User=agl-driver
Environment=XDG_RUNTIME_DIR=/run/user/1001/
+Environment=QT_QPA_PLATFORM=wayland
ExecStart=/usr/bin/launcher
Restart=on-failure
diff --git a/recipes-demo/launcher/launcher_git.bb b/recipes-demo/launcher/launcher_git.bb
index c46a4a182..2f8c5182e 100644
--- a/recipes-demo/launcher/launcher_git.bb
+++ b/recipes-demo/launcher/launcher_git.bb
@@ -8,7 +8,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
DEPENDS = "\
qtbase \
qtdeclarative \
- qtquickcontrols2 \
libqtappfw \
wayland-native \
wayland \
@@ -23,12 +22,13 @@ PV = "1.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
file://launcher.service \
-"
+ file://0001-Migrate-to-Qt-6.patch \
+ "
SRCREV = "4be88c049f31b7659e09223857b92ca531835039"
S = "${WORKDIR}/git"
-inherit qmake5 systemd pkgconfig
+inherit qt6-qmake systemd pkgconfig
PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"