summaryrefslogtreecommitdiffstats
path: root/recipes-demo/libqtappfw/libqtappfw_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-09-10 13:11:15 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-21 13:18:47 +0000
commitab559762e86055ead1ffa2a5f93c91a4f743f9c4 (patch)
tree9036a8133bc33727a627c824c9935a733b1bdef9 /recipes-demo/libqtappfw/libqtappfw_git.bb
parent56e0907b8ca1d7cbdd80f3805ef8d45a09f98aa1 (diff)
Switch Qt demo apps to gRPC launcher API
Changes: - Update SRCREV in libqtappfw, launcher, and homescreen recipes to pick up gRPC API changes. - Update libqtappfw recipe for switch to meson instead of CMake, and add new protobuf and gRPC dependencies. - Update launcher recipe to pull in new libqtappfw dependency, and update some formatting for consistency with the other recipes. Bug-AGL: SPEC-4559 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6ec0f53a0cc68bcf9b434086d99e8849c11198f3
Diffstat (limited to 'recipes-demo/libqtappfw/libqtappfw_git.bb')
-rw-r--r--recipes-demo/libqtappfw/libqtappfw_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-demo/libqtappfw/libqtappfw_git.bb b/recipes-demo/libqtappfw/libqtappfw_git.bb
index 326685fe..a390d027 100644
--- a/recipes-demo/libqtappfw/libqtappfw_git.bb
+++ b/recipes-demo/libqtappfw/libqtappfw_git.bb
@@ -8,22 +8,27 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = " \
qtbase \
+ qtbase-native \
qtdeclarative \
qtwebsockets \
glib-2.0 \
bluez-glib \
connman-glib \
libmpdclient \
+ protobuf-native \
+ grpc-native \
+ protobuf \
+ grpc \
"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "a2d991a54f77017ced1558d289bcb83d73fe2a35"
+SRCREV = "5bf2b9d30ccea0f5468b22abedbe1629691eab15"
S = "${WORKDIR}/git"
# PV needs to be modified with SRCPV to work AUTOREV correctly
PV = "2.0+git${SRCPV}"
-inherit cmake_qt5 pkgconfig
+inherit meson pkgconfig
RRECOMMENDS:${PN} += "bluez5 connman mpd"