summaryrefslogtreecommitdiffstats
path: root/recipes-demo/libqtappfw
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-09-10 13:11:15 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-22 10:20:55 +0000
commit7cae7f082bbf22114a3a5298733d269e4a04da8d (patch)
tree5301c2cf165d844c4f7e71ed8df84421c139f7cd /recipes-demo/libqtappfw
parent084773665942096e7bf2140e9f0e88346d58e54b (diff)
Switch Qt demo apps to gRPC launcher API
Changes: - Update SRCREV in libqtappfw, launcher, and homescreen recipes to pick up gRPC API changes. - Update libqtappfw recipe for switch to meson instead of CMake, and add new protobuf and gRPC dependencies. - Update launcher recipe to pull in new libqtappfw dependency, and update some formatting for consistency with the other recipes. Bug-AGL: SPEC-4559 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ib01e3b9d9bf5b422f69012bfdbd415628bbb9ab9
Diffstat (limited to 'recipes-demo/libqtappfw')
-rw-r--r--recipes-demo/libqtappfw/libqtappfw_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-demo/libqtappfw/libqtappfw_git.bb b/recipes-demo/libqtappfw/libqtappfw_git.bb
index 326685fe..85462264 100644
--- a/recipes-demo/libqtappfw/libqtappfw_git.bb
+++ b/recipes-demo/libqtappfw/libqtappfw_git.bb
@@ -8,22 +8,27 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = " \
qtbase \
+ qtbase-native \
qtdeclarative \
qtwebsockets \
glib-2.0 \
bluez-glib \
connman-glib \
libmpdclient \
+ protobuf-native \
+ grpc-native \
+ protobuf \
+ grpc \
"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "a2d991a54f77017ced1558d289bcb83d73fe2a35"
+SRCREV = "187ab41bb5082d07b6a81fb9dba2564f39e9d770"
S = "${WORKDIR}/git"
# PV needs to be modified with SRCPV to work AUTOREV correctly
PV = "2.0+git${SRCPV}"
-inherit cmake_qt5 pkgconfig
+inherit meson pkgconfig
RRECOMMENDS:${PN} += "bluez5 connman mpd"