summaryrefslogtreecommitdiffstats
path: root/recipes-demo/messaging/messaging_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-07-07 16:26:45 +0000
committerDenys Dmytriyenko <denys@konsulko.com>2022-07-11 19:56:28 +0000
commitaa6100e48b4beabe8cb5371fb88a98aebe58a996 (patch)
tree0e37943d5619e687b930afb527c21657ef4110b9 /recipes-demo/messaging/messaging_git.bb
parent32bc374d3ab668a00dcd3083613d51f0ae59398d (diff)
recipes-demo: update application's .desktop files for systemd execution
Initial version of applaunchd with systemd_manager still uses .desktop files for enumeration purposes and requires DBusActivatable=true to indicate apps that should be launched as systemd services. This will be addressed in the new revision of applaunchd and hopefully .desktop files dropped completely. Bug-AGL: SPEC-4466 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Change-Id: I3bcea79ec653fc834a39be4135ed4c008d5979db
Diffstat (limited to 'recipes-demo/messaging/messaging_git.bb')
-rw-r--r--recipes-demo/messaging/messaging_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-demo/messaging/messaging_git.bb b/recipes-demo/messaging/messaging_git.bb
index 31ca7ce0..c7ce8cb3 100644
--- a/recipes-demo/messaging/messaging_git.bb
+++ b/recipes-demo/messaging/messaging_git.bb
@@ -17,6 +17,12 @@ S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
+do_install:append() {
+ sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/messaging.desktop
+ echo "DBusActivatable=true" >> ${D}${datadir}/applications/messaging.desktop
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += "libqtappfw"