summaryrefslogtreecommitdiffstats
path: root/recipes-demo/navigation/poiapp-api-key_1.0.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-demo/navigation/poiapp-api-key_1.0.bb
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-demo/navigation/poiapp-api-key_1.0.bb')
-rw-r--r--recipes-demo/navigation/poiapp-api-key_1.0.bb21
1 files changed, 0 insertions, 21 deletions
diff --git a/recipes-demo/navigation/poiapp-api-key_1.0.bb b/recipes-demo/navigation/poiapp-api-key_1.0.bb
deleted file mode 100644
index d353d7dd..00000000
--- a/recipes-demo/navigation/poiapp-api-key_1.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "AGL Reference POI application API key."
-DESCRIPTION = "Preload the API key for the AGL POI application."
-HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
-SECTION = "apps"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-
-inherit allarch
-
-do_fetch[noexec] = "1"
-do_unpack[noexec] = "1"
-do_compile[noexec] = "1"
-
-POIAPP_CLIENT_ID ?= ""
-POIAPP_API_KEY ?= ""
-
-do_install () {
- install -d ${D}${sysconfdir}
- echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
- echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
-}